Attended transfer fails

I have an incoming ZAP call from extension 3666 which connects to SIP extension 6008.
Then SIP extension 6008 dials #* and 6007 (attended transfer).
The SIP extension 6007 rings but when the call is picked up, it fails with a beeperr message and 3666 is back with 6008.

6007 and 6008 are part of a hunt group.

[Apr 19 13:16:51] VERBOSE[401] logger.c:     -- AGI Script dialparties.agi completed, returning 0
[Apr 19 13:16:51] DEBUG[401] app_macro.c: Executed application: AGI
[Apr 19 13:16:51] VERBOSE[401] logger.c:     -- Executing [s@macro-dial:7] Dial("Local/6007@from-internal-xfer-2b44,2", "SIP/6007||tTwW") in new stack
[Apr 19 13:16:51] VERBOSE[401] logger.c:     -- Called 6007
[Apr 19 13:16:51] VERBOSE[401] logger.c:     -- SIP/6007-0000110e is ringing
[Apr 19 13:16:54] VERBOSE[401] logger.c:     -- SIP/6007-0000110e answered Local/6007@from-internal-xfer-2b44,2
[Apr 19 13:16:54] VERBOSE[32709] logger.c:     -- Stopped music on hold on Zap/26-1
[Apr 19 13:16:54] VERBOSE[401] logger.c:     -- Executing [h@macro-dial:1] Macro("Local/6007@from-internal-xfer-2b44,2", "hangupcall") in new stack
[Apr 19 13:16:54] VERBOSE[401] logger.c:     -- Executing [s@macro-hangupcall:1] ResetCDR("Local/6007@from-internal-xfer-2b44,2", "w") in new stack
[Apr 19 13:16:54] VERBOSE[32709] logger.c:     -- <SIP/6008-0000110c> Playing 'beeperr' (language 'en')

include => parkedcalls
include => from-internal-custom
include => ext-fax
include => ext-local-confirm
include => findmefollow-ringallv2
include => from-internal-additional
; This causes grief with '#' transfers, commenting out for the moment.
; include => bad-number
exten => s,1,Macro(hangupcall)
exten => h,1,Macro(hangupcall)

What could the problem be?

Might want to check the feature codes in FreePBX to make sure #* is set up for attended transfer. I believe the default is 2. If you’ve changed it, could be that the # sequence could be a problem in itself.


I changed it:

# features_featuremap_additional.conf

# features_general_custom.conf
xfersound = beep
xferfailsound = beeperr
transferdigittimeout => 5
featuredigittimeout => 3000

works fine though.

#* also works, except for the case I reported, where the only “different” setting I notice is that the 6008/6007 extensions are within a ring group.

Thanks anyway.

Is this the only ring group with which you are having problems?
You might try setting it up as a queue rather than a ring group, also, possibly changing it back to *2 to see if that makes a difference.