ATT IPFlex registration issue


#1

We got a new phone service from ATT. They’ve installed ATT IPFlex and provided 3 IP addresses. 2 IP address is what they call is border elements and 1 IP address for SIP signaling.

I have a FreePBx 15.0.16.77 installed behind a pfsense 2.4 firewall on the DMZ zone. For testing purposes pfsense allows all traffic coming from those IP addresses, including 5060 and RTP ports (10000-38000)

I created 2 pjsip trunks using the border element IP addresses, setup inbound and outbound routes but I am not sure where I should use the last IP (SIP signaling).

I tried to enter it under Settings -> Asterisk SIP Settings -> General SIP Settings at the NAT Settings field as External Address. But it did not help.

(When I click on the Detect Network Settings, it gets the pfsense WAN public IP. So, I manually entered the SIP signaling IP in this field. I am guessing it should get the SIP signaling IP, maybe?)

I also tried the External IP field under SIP Settings (chan_pjsip) tab.

FreeBPX always displays OFFLINE as status. When I place a call, it says that “All circuits are busy now”.

Can anyone point me to a right direction?

Thank you for your help in advance.