AT&T/Cricket Blocking Traffic

Hello, I’m wondering if anyone has experience in AT&T or Cricket (a subsidiary of AT&T) blocking VoIP traffic. I have a FreePBX install, and am trying to set up softphones. I’m currently using Zoiper as my softphone client.

Everything works great if the Cricket cell phone running Zoiper is on WiFi. However, as soon as I switch to their 4G/LTE network, I get no inbound audio. Running a network status on the phone while a call is ongoing shows 0kb/s coming into the phone, which means audio packets are not reaching the phone. As soon as I switch to a WiFi network, even in the middle of a call, I get the audio. I’ve tried two different trunk providers (one of them being SIPStation), and same effect.

Per the instructions on Zoiper’s website, I’ve tried all different combinations of the STUN and RPORT settings, with no help. I get no inbound audio, and the cellphone data network usage is still 0kb/s when a call is ongoing.

I’m being lead to the conclusion that AT&T is somehow blocking VoIP traffic over their 4g/LTE network, and wondered if anyone came across the same roadblock. A Google search turned up nothing expect a discussion on AT&T’s forums many years back about AT&T blocking port 5060 on their Uverse services.

Interestingly enough, when I was running a FreePBX server in-house off our Uverse connection to the Internet, Zoiper worked fine on Cricket’s 4g/LTE network. So it appears AT&T is blocking traffic to VoIP providers outside the AT&T network. Anyone have any experiences with this? Thank you very much.

I had a situation last year where anyone calling certain DID’s from an AT&T cell phone would get a message saying this number is out of service. If they called from a landline, or any other cellular provider they got through. Crazy huh? I had to call AT&T and report this behavior and it took 2 weeks to get resolved.

One-way audio is almost always a NAT setting problem. A SIP trace of the call will tell you which phone’s NAT is not set correctly.

PBX on-site, or in the cloud? If the former, confirm that Zoiper works properly when it’s on a Wi-Fi network other than yours.

Behind a NAT, or on a public IP? If the former, confirm that your NAT settings in Settings -> Asterisk SIP settings are correct, that that your router forwards the UDP port range specified by RTP Port Ranges to the PBX.

Using pjsip, or chan_sip? Bind port is 5060, 5160 or something else?

When attempting to call using mobile data, confirm that outbound audio is present. If not, look at the SIP 200 OK sent from the PBX to the phone and confirm that the SDP is requesting audio on the PBX’s public IP. If oubound audio is ok, check that the RTP sent from PBX to phone is going to the same IP and port that the incoming RTP is coming from.

If you still have trouble, post a (suitably redacted) SIP trace.

Thank you all for the helpful suggestions. I will do some more investigation and report back. Our FreePBX server is remotely hosted; not on-site.

Very often using Zoipers iax2 connection will get through where your provider is blocking sip.

Verizon ACTIVELY blocks SIP on both their wireless HotSpots and the phones using tethering - look deep enough into your agreement and you will find where they say they are entitled to block competing services.

VPN can sometimes get you around it - or like Dicko says - IAX2 is usually not recognized.

1 Like

Thanks @dicko and @GSnover. I changed the extension to iax2 and configured such in Zoiper. That fixed the problem. I’m sure it’s a 4G/LTE SIP blocking, as I’ve changed no other settings other than changing this one extension to iax2.

I’m glad that you got it working, though I’d really like to know what the SIP issue was.

IMHO it’s unlikely they would be actively blocking. I hope that a member with a phone on Cricket or AT&T can take a look at what goes wrong.

AT&T doesn’t block VoIP in general; Skype, FaceTime, Messenger, WhatsApp, Viber, Hangouts, SideLine, Line2, … all work fine.

I just did two tests with CSipSimple <-> FreePBX; both had good bidirectional audio. I admit that they weren’t definitive, limited by my present resources. The first used a Samsung tablet with an AirVoice Wireless SIM (AT&T MVNO). The other used a Motorola phone with an SFR SIM, roaming on AT&T.

I don’t know whether it mattered in this case, but my PBX listens on a non-standard port rather than 5060.

Some reasons why IAX2 is IMO not a good general workaround:

  1. Won’t work with the native VoIP function built into most Android dialers.
  2. Won’t work with other fine softphones (CSipSimple, Bria, Grandstream).
  3. Won’t work with other PBXes (FreeSWITCH, 3CX, Vodia), though some offer an alternative tunnel mechanism.
  4. For those who don’t need a PBX or are satisfied with the PBX features of their provider, many don’t support IAX (even some that are Asterisk based).

Your observed symptoms seem strange for blocking. The signaling was apparently normal – did they tweak the SDP so RTP went to the wrong address or port? It certainly would be easier to just block the SIP ports.

Since it’s easy to capture a SIP trace with both FreePBX and CSipSimple, it should be easy to see what is going wrong.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.