FreePBX | Register | Issues | Wiki | Portal | Support

Asterisk Will Not Start and Motif Issues


#1

I hope that this is the right forum to post this in but, I am running the Beta of FreePBX so I assumed this would be the right place. I have two issues I would like to get solved.

  1. We had some power issues last night and our PBX has not recovered. Everything starts up but asterisk has not been able to recover. We are receiving the following logs over and over again:

[2012-12-21 12:40:33] WARNING[12504] db.c: Couldn’t prepare statement ‘CREATE TABLE IF NOT EXISTS astdb(key VARCHAR(256), value VARCHAR(256), PRIMARY KEY(key))’: disk I/O error
[2012-12-21 12:40:33] WARNING[12504] db.c: Couldn’t create astdb table: disk I/O error
[2012-12-21 12:40:33] Asterisk 11.0.1 built by root @ jenkins6.schmoozecom.net on a x86_64 running Linux on 2012-11-21 22:19:36 UTC
[Dec 21 12:40:33] VERBOSE[12513] config.c: == Parsing ‘/etc/asterisk/logger.conf’: Found
[Dec 21 12:40:33] VERBOSE[12513] config.c: == Parsing ‘/etc/asterisk/logger_general_additional.conf’: Found
[Dec 21 12:40:33] VERBOSE[12513] config.c: == Parsing ‘/etc/asterisk/logger_general_custom.conf’: Found
[Dec 21 12:40:33] VERBOSE[12513] config.c: == Parsing ‘/etc/asterisk/logger_logfiles_additional.conf’: Found
[Dec 21 12:40:33] VERBOSE[12513] config.c: == Parsing ‘/etc/asterisk/logger_logfiles_custom.conf’: Found
[2012-12-21 12:40:33] VERBOSE[12513] config.c: == Parsing ‘/etc/asterisk/asterisk.conf’: Found

I have done a disk check with UBCD and it turned up clean so I moved onto trying to repair the MySQL database with mysqlcheck and that had no effect. If anyone has any suggestions please share as until this is fixed our telephones are down and I really do not want to reinstall FreePBX.

  1. The second issue is with motif. We have been using Google Voice with motif since we got the FreePBX Beta. The problem is that motif seems to disconnect from Google Voice and not reconnect. In the motif config panel it says that it is connected but, when we call out all we get is constant ringing and when people call in they get the Google Voicemail. It requires the server to be restarted to get it to work again.

I really need someone’s help.

Thanks


#2

We were both sitting at the same churrasqueira enjoying some rodizio while that developers of channel motif gave us the front and back story.

I can confirm without a shadow of a doubt that I ate too much!


#3

I have no conspiracy theories, cecking up on my CRS in old emails, I can confirm tm100 that he did in fact post originally “October”, even if by my criteria the last day of October is not not “months ago” from last week I apologize :-).

I had similar issues to the OP, hence my caution about unfinished/unproven code, perhaps inelegantly expressed, and so to wait. All my issues seem to have been resolved by moving to asterisk-11.2.0-rc1.tar.gz ( I am using FreePB from http://www.freepbx.org/v2/svn/freepbx/branches/2.11/ ), agreed that my own solution itself goes back to code lacking imprimatur, but IWFM.

Anyway in this season of good-will I wish you both the best.


#4

To point you in the right direction, astdb is an sqlite database not mysql.


#5

I know this is a total noob question but, how would I go about repairing this database? I somewhat know how to use MySQL but, I have no clue about sqlite.


#6

usually a .dump and restore , but if there is a hardware error in the diskfile then there might be a problem, probably copy the database from your last backup, alternatively create a new empty astdb table and let FreePBX populate it,


#7

So I was able to do .dump but that did not help. I have no clue how to create a database. Any help? I feel like such and idiot.


#8

So I was able to do .dump but that did not help. I have no clue how to create a database. Any help? I feel like such and idiot.


#9

As I said just copy /var/lib/asterisk/astdb.sqlite3 from your last good backup back into /var/lib/asterisk/

If you don’t have a backup, then apart from telling you you should . . . from:-

https://wiki.asterisk.org/wiki/display/AST/SQLite3+astdb+back-end

you can also use astdb2sqlite3 to regenerate it.

Anywhich way you get a working sqlite3 astdb database the resore process will overwrite everything in it.

If .dump worked then you will need to RTFM for sqlite3 to know how to “restore” into a new datbase, really it is alomost exactly the same as mysql which you have a passing knowledge of, If you won’t RTFM and havn’t tried google yet (It really is a good research tool for questions like this) try

http://letmegooglethatforyou/?q=backup+and+restore+sqlite3


#10

Thank you very much. I ended up deleting astdb.sqlite3 and astdb.sqlite3-journal in /var/lib/asterisk and rebooting. I really don’t know all that much SQL but, I am just familiar enough with MySQL to host a few Minecraft servers. I also created daily backups per your recommendation. Now onto why Motif drops connection all the time.


#11

Motif and Asterisk are still at your bleeding edge deployment level and have some problems right now. Digium’s efforts are directed at asterisk 11 and we are still very beta in that world.

Just a reminder, don’t expect beta code to work, that’s why it’s beta . . . :wink:


#12

Hopefully it will come out of beta soon. I did not know if this was a known issue that had a fix as of now. Thanks very much


#13

Unless you are brave, and want to play developer and contribute bug reports and fixes, the only fix for beta code not doing what you “demand” of it is to wait until it isn’t anymore.

:wink:


(Andrew Nagy) #14

Asterisk 11 isn’t beta. They removed that title months ago (October) you can call it what you want personally but please don’t confuse forum members.

http://www.asterisk.org/downloads


#15

I don’t believe I said Asterisk 11 was beta, the OP stated " . . . I am running the Beta of FreePBX . . "

Informationally Digium have these released tarballs of Asterisk 11 available from

http://downloads.asterisk.org/pub/telephony/asterisk/releases/

2012-11-28 asterisk-11.0.0-beta1.tar.gz
2012-11-28 asterisk-11.0.0-beta2.tar.gz
2012-11-28 asterisk-11.0.0-rc1.tar.gz
2012-11-28 asterisk-11.0.0-rc2.tar.gz
2012-11-28 asterisk-11.0.0.tar.gz
2012-11-28 asterisk-11.0.1.tar.gz
2012-12-06 asterisk-11.0.2.tar.gz
2012-11-28 asterisk-11.1.0-rc1.tar.gz
2012-12-06 asterisk-11.1.0-rc3.tar.gz
2012-12-10 asterisk-11.1.0.tar.gz
2012-12-10 asterisk-11.2.0-rc1.tar.gz

So I will give you three and a half weeks ago :wink:


(Andrew Nagy) #16

Now that we’ve stated that Asterisk isn’t in beta (though freepbx is but the motif module for freepbx isn’t)

It’s always good to know what you cant do when you setup and use google voice in freepbx.

First of all you can never log in to your email account on the web again. If you do you are essentially telling google “Hey I’m on gtalk on the web now” unfortunately when this happens no message is sent to Asterisk, therefore Asterisk will merrily chime along thinking everything is ok. The only way to fix it at that point is reload chan_motif and res_xmpp. Otherwise restart asterisk.


(Andrew Nagy) #17

Not to start an argument here but that site is a little strange. It lists the first beta as being released on the 28th of November but that’s completely incorrect. See this blog announcement made on October 31st: http://blogs.digium.com/2012/10/31/asterisk-11-now-available/

Further proof that they recently changed their whole site and those dates/times are completely incorrect: http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/

asterisk-0.1.0.tar.gz	28-Nov-2012 19:16	124K

Unless you want to tell me that Asterisk Version 0.1.0 was released last month.

So I will take back my October announcement. Thanks. :slight_smile:


#18

I created dedicated accounts for each line so that is not the issue. I have not logged into any of those for at least a month now. Any other ideas on what it could be? If there are any logs I can provide you let me know and I will. Thank you very very much for your help as I would never be able to figure this out as I am new to the Asterisk world.


#19

I agree that the Changelogs state that 11.0.0. went production on 10-25 and was publically announced on 10.31. I agree to split our difference (I am sure your post originally said September, so I am a little confused as to how many “months ago” you now claim , but I suffer from CRS :slight_smile: ), anyway have a great “holiday” whatever that entails for you.

Regards to all.


(Andrew Nagy) #20

Sorry to stifle your conspiracy theories but I never said september, I’ve always said october since I was in the room with the freepbx developers and the digium developers during astricon when they announced the release