Asterisk-version-switch fails


#1

Have a server that seems to be stuck on 16.3 and tried to run asterisk-version-switch and the command fails

Line 43 & 46 errors with Error: Trying to remove “sangoma-pbx”, which is protected

Loaded plugins: fastestmirror, versionlock

Determining fastest mirrors
sng-base | 3.6 kB 00:00:00
sng-epel | 2.9 kB 00:00:00
sng-extras | 2.9 kB 00:00:00
sng-pkgs | 3.4 kB 00:00:00
sng-updates | 2.9 kB 00:00:00
(1/6): sng-base/7/x86_64/group_gz | 153 kB 00:00:01
(2/6): sng-extras/7/x86_64/primary_db | 206 kB 00:00:02
(3/6): sng-pkgs/7/x86_64/primary_db | 859 kB 00:00:05
(4/6): sng-updates/7/x86_64/primary_db | 4.5 MB 00:00:27
(5/6): sng-base/7/x86_64/primary_db | 6.1 MB 00:00:34
(6/6): sng-epel/7/x86_64/primary_db | 7.3 MB 00:00:36

Package jansson-2.10-1.el7.x86_64 already installed and latest version
Package sangoma-pbx-2012-1.sng7.noarch already installed and latest version
–> Running transaction check
—> Package asterisk16.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-addons.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-addons-bluetooth.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-addons-core.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-addons-mysql.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-addons-ooh323.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-core.x86_64 0:16.3.0-1.sng7 will be erased
–> Processing Dependency: asterisk-core for package: freepbx-14.1-1.sng7.x86_64
—> Package asterisk16-curl.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-dahdi.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-doc.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-flite.x86_64 0:2.4-2_2505af1.sng7 will be erased
—> Package asterisk16-g729.x86_64 0:1711-2.sng7 will be erased
—> Package asterisk16-odbc.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-ogg.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-res_digium_phone.x86_64 0:3.5.0-1.sng7 will be erased
—> Package asterisk16-resample.x86_64 0:16.3.0-1.sng7 will be erased
—> Package asterisk16-voicemail.x86_64 0:16.3.0-1.sng7 will be erased
—> Package jansson-devel.x86_64 0:2.10-1.el7 will be installed
—> Package jansson-devel-doc.noarch 0:2.10-1.el7 will be installed
–> Running transaction check
—> Package freepbx.x86_64 0:14.1-1.sng7 will be erased
–> Processing Dependency: freepbx for package: sangoma-pbx-2012-1.sng7.noarch
–> Running transaction check
—> Package sangoma-pbx.noarch 0:2012-1.sng7 will be erased
–> Finished Dependency Resolution
Error: Trying to remove “sangoma-pbx”, which is protected
–> Running transaction check
–> Finished Dependency Resolution
Error: Trying to remove “sangoma-pbx”, which is protected
Leaving Shell

asterisk16 has now been verified to be installed

Yes.
res_digium_phone is installed. You will need to reinstall this module after the switch
/usr/local/sbin/asterisk-version-switch: line 156: -: command not found
Checking for orphaned asterisk files in /usr/lib64/asterisk/modules…
finished checking
Restarting Asterisk…
Running FreePBX shutdown…

Core FastAGI Server is not running
Stopping UCP Node Server
[>---------------------------] 1 sec
Stopped UCP Node Server
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] 1 sec
Running FreePBX startup…
Running Asterisk pre from Sysadmin module
Running Sysadmin Hooks
Unable to locate the FreePBX BMO Class 'Firewall’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install firewall 2) fwconsole ma enable firewall
Starting Asterisk…
[============================] 4 secs
Asterisk Started
Running Asterisk post from Core module
Running Asterisk post from Ucp module
Starting UCP Node Server…
[>---------------------------] 1 sec
Started UCP Node Server. PID is 5505
Regenerate FreePBX Dialplan…
Reloading FreePBX
Successfully reloaded
Chowning all needed files
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissions…
Setting base permissions…Done
Setting specific permissions…
41347 [============================]
Finished setting permissions

rpm -qa | grep asterisk

asterisk16-dahdi-16.3.0-1.sng7.x86_64
asterisk16-flite-2.4-2_2505af1.sng7.x86_64
asterisk-sounds-core-ja-ulaw-1.5-2.sng7.noarch
asterisk-sounds-core-en-wideband-1.5-2.sng7.noarch
asterisk16-16.3.0-1.sng7.x86_64
asterisk16-curl-16.3.0-1.sng7.x86_64
asterisk-sounds-core-en-alaw-1.5-2.sng7.noarch
asterisk16-addons-mysql-16.3.0-1.sng7.x86_64
asterisk16-voicemail-16.3.0-1.sng7.x86_64
asterisk16-resample-16.3.0-1.sng7.x86_64
asterisk-sounds-core-it-ulaw-1.5-2.sng7.noarch
asterisk-sounds-core-es-ulaw-1.5-2.sng7.noarch
asterisk-sounds-extra-en-wideband-1.5-2.sng7.noarch
asterisk16-res_digium_phone-3.5.0-1.sng7.x86_64
asterisk16-addons-core-16.3.0-1.sng7.x86_64
asterisk16-doc-16.3.0-1.sng7.x86_64
asterisk-version-switch-5.2-1.sng7.noarch
asterisk16-odbc-16.3.0-1.sng7.x86_64
asterisk16-g729-1711-2.sng7.x86_64
asterisk-sounds-core-en_GB-ulaw-1.5-2.sng7.noarch
asterisk-sounds-core-en-ulaw-1.5-2.sng7.noarch
asterisk-sounds-extra-en-ulaw-1.5-2.sng7.noarch
asterisk-sounds-extra-en-alaw-1.5-2.sng7.noarch
asterisk16-core-16.3.0-1.sng7.x86_64
asterisk16-addons-ooh323-16.3.0-1.sng7.x86_64
asterisk-sounds-moh-opsound-sln-2.03-1.1.noarch
asterisk16-ogg-16.3.0-1.sng7.x86_64
asterisk16-addons-bluetooth-16.3.0-1.sng7.x86_64
asterisk-sounds-moh-opsound-alaw-2.03-1.1.noarch
asterisk16-addons-16.3.0-1.sng7.x86_64
asterisk-sounds-core-fr-ulaw-1.5-2.sng7.noarch

Not sure where to go from here


(Itzik) #2

asterisk-version-switch seems to be broken now.


#3

Thanks for the reply.

Not sure if that it is or not - I had another system that had the issue of updating the version of Asterisk which I was able to get fixed using this Cant yum update

This seems to be a different type of error and I cant update using the link mentioned


(Brian) #4

(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.