Asterisk version not allowing WebRTC module install weirdness

Problem, please help!

I tried to install the WebRTC module and recieved the following error:

Errors with selection:

WebRTC Phone cannot be installed:
Requires engine asterisk (>= 11.5), you have: asterisk 10.12.3
Please try again after the dependencies have been installed.

System Admin shows me the following:

PBX Firmware: 5.211.65-6
PBX Service Pack: 1.0.0.0

I had gone through all the update scripts one by one to get it to this point. Something is amiss, so to the console:

[[email protected] ~]# yum update asterisk11
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
base | 2.0 kB 00:00
extras | 1.3 kB 00:00
pbx | 1.3 kB 00:00
schmooze-commercial | 1.3 kB 00:00
updates | 1.3 kB 00:00
Setting up Update Process
Package(s) asterisk11 available, but not installed.
No Packages marked for Update
[[email protected] ~]#

Thanks SkykingOH, had that part figured out.

Trying to understand why my system thinks its at Asterisk 10 and doesn’t want to update to 11.

You have to use Asterisk 11

note lines 5, 8 and 20 of my original post (don’t count blank lines)

Because you are trying to upgrade a non-existent package. You never installed asterisk 11. Trying asterisk-version-switch instead

Awesome, worked like a charm.

Thanks tm1000 !!!