FreePBX | Register | Issues | Wiki | Portal | Support

Asterisk upgrade has broken my database

asterisk
Tags: #<Tag:0x00007fcd21096d70>

#1

I have had system running for quite some time and on the weekend updated the latest packages which seemed at the time to have worked. I found out this morning that it has infact killed the system.

It seems several tables are now corrupt and mariad will not start.

I tried repairing the database with

myisamchk --recover --extend-check --force /var/lib/mysql/mysql/*.MYI

When this runs I get some tables reporting
Found block that points outside data file at xx

One table returns
Found block with too small length at xxxx: skipped

Any other things to try?

Peter.


(Dave Burgess) #2

Get a new hard drive, copy the old data onto it, and put it in the system. In my experience, these are hardware problems.


#3

Hi @cynjut. Thanks for the help so far… however., pretty sure its not the hard disk because its on a VM and every thing else is humming along.

Don’t doubt something has clobbered the data.

I 've moved the data to a new location and pointed mariadb to it… still segfaults.

I’ve started mariadb with an empty data directory. Its happy with that.

So pretty certain the database is corrupted. Does anyone have any ideas about getting it back from here? I’ve had corrupted databases on other mariadb projects before and I’ve been able to repair them… but this one is not playing the game.

Is my only choice blow it all away and start again?

If so, what config files should I keep and push back?

Peter.


#4

After installing mysql/mariadb

mysql -s -e “show databases”

would normally return

Database
information_schema
mysql
performance_schema

You will need these databases before any other databases you add later will work properly.


(system) #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.