FreePBX | Register | Issues | Wiki | Portal | Support

Asterisk Update cause "SRTCP unprotect failed"

asterisk
Tags: #<Tag:0x00007f749e8e11a0>

(IvoR) #1

Hi all

Last Friday, we update the PBX without a reboot, which we do last night (in the night from Sunday to Monday). Since today in the morning, we have the problem (3 times in two hours), that the phones are “not registered”, but the “sip show peers” looks normal.

Two time before this happen, we see these error in the full log:

[2019-04-15 08:33:48] VERBOSE[14675][C-000003b9] res_srtp.c: SRTCP unprotect failed because of unable to perform desired validation
[2019-04-15 09:37:07] VERBOSE[29716][C-000001fa] res_srtp.c: SRTCP unprotect failed because of unable to perform desired validation

No so after the 3rd time, then, I just can see a lot of these log entries:

[2019-04-15 10:21:19] VERBOSE[7360][C-00000007] res_srtp.c: SRTCP unprotect failed because of authentication failure


Update from last Friday:

[root@pbx01 asterisk]# yum history info 165
Loaded plugins: fastestmirror, versionlock
Transaction ID : 165
Begin time     : Fri Apr 12 07:13:18 2019
Begin rpmdb    : 864:302c87035f5d54db139847270d11b110aed2ab9c
End time       :            07:13:26 2019 (8 seconds)
End rpmdb      : 864:3ff384ad10c996ae20e5f4a179a8a340cbab484e
User           : root <root>
Return-Code    : Success
Transaction performed with:
    Installed     rpm-4.11.3-32.el7.x86_64                        @sng-base
    Installed     yum-3.4.3-158.7.sng7.noarch                     @sng-pkgs
    Installed     yum-metadata-parser-1.1.4-10.el7.x86_64         installed
    Installed     yum-plugin-fastestmirror-1.1.31-46.el7_5.noarch @sng-updates
Packages Altered:
    Updated asterisk13-13.22.0-1.sng7.x86_64                  @sng-pkgs
    Update             13.26.0-1.sng7.x86_64                  @sng-pkgs
    Updated asterisk13-addons-13.22.0-1.sng7.x86_64           @sng-pkgs
    Update                    13.26.0-1.sng7.x86_64           @sng-pkgs
    Updated asterisk13-addons-bluetooth-13.22.0-1.sng7.x86_64 @sng-pkgs
    Update                              13.26.0-1.sng7.x86_64 @sng-pkgs
    Updated asterisk13-addons-core-13.22.0-1.sng7.x86_64      @sng-pkgs
    Update                         13.26.0-1.sng7.x86_64      @sng-pkgs
    Updated asterisk13-addons-mysql-13.22.0-1.sng7.x86_64     @sng-pkgs
    Update                          13.26.0-1.sng7.x86_64     @sng-pkgs
    Updated asterisk13-addons-ooh323-13.22.0-1.sng7.x86_64    @sng-pkgs
    Update                           13.26.0-1.sng7.x86_64    @sng-pkgs
    Updated asterisk13-core-13.22.0-1.sng7.x86_64             @sng-pkgs
    Update                  13.26.0-1.sng7.x86_64             @sng-pkgs
    Updated asterisk13-curl-13.22.0-1.sng7.x86_64             @sng-pkgs
    Update                  13.26.0-1.sng7.x86_64             @sng-pkgs
    Updated asterisk13-dahdi-13.22.0-1.sng7.x86_64            @sng-pkgs
    Update                   13.26.0-1.sng7.x86_64            @sng-pkgs
    Updated asterisk13-doc-13.22.0-1.sng7.x86_64              @sng-pkgs
    Update                 13.26.0-1.sng7.x86_64              @sng-pkgs
    Updated asterisk13-odbc-13.22.0-1.sng7.x86_64             @sng-pkgs
    Update                  13.26.0-1.sng7.x86_64             @sng-pkgs
    Updated asterisk13-ogg-13.22.0-1.sng7.x86_64              @sng-pkgs
    Update                 13.26.0-1.sng7.x86_64              @sng-pkgs
    Updated asterisk13-res_digium_phone-3.4.10-1.sng7.x86_64  @sng-pkgs
    Update                              3.5.0-1.sng7.x86_64   @sng-pkgs
    Updated asterisk13-resample-13.22.0-1.sng7.x86_64         @sng-pkgs
    Update                      13.26.0-1.sng7.x86_64         @sng-pkgs
    Updated asterisk13-voicemail-13.22.0-1.sng7.x86_64        @sng-pkgs
    Update                       13.26.0-1.sng7.x86_64        @sng-pkgs
history info
[root@pbx01 asterisk]# 

Any idea about?

gruss ivo


(IvoR) #2

… at the moment, it happens every 5-10 minutes


(IvoR) #3

We revert all the yum updates from Friday and now, it works fine again.

Something looks wrong with the asterisk update


(United States) #4

I had a similar issue. Tried rebooting and every time it seemed it wouldn’t connect to Asterisk. I tried to restart astersik via CLI, and it would not shut down. After trying several times, with the same result, I rebooted via the GUI and it seems to be working now.


(IvoR) #5

hmmm, We try a lot of different thing, the only working path was a revert to the version before the yum update.


(United States) #6

I got some assistance and there is an issue with the update.


(Joseph Hayhoe) #7

Was this tracked in a FreePBX issue tracker? I experienced the same issue earlier today and wanted to see if there was more context. Looks like that package was pulled earlier today from the repos and is no longer available.


(IvoR) #8

I can’t find any issue in the tracker, but that’s right, it’s no longer in the repo.