Asterisk System in Belgium - Cannot make international calls


Can anyone help?

I have just installed a FeePBX/Asterisk system in our Belgian Office and have been unable to configure it to make international calls via the local ISDN line. To get around this, I have routed all international calls via our UK Office, but this is not ideal.

If I route calls prefixed with 00 to the ZAP channel, the Belgian PSTN responds with a message to say that the number is incorrect and suggests dialing their Directory Enquiries.

Also, I cannot dial the Belgian Directory Enquiries services on 1204,1207,1304 & 1307 - the line hangs up immediately.

As a point of interest, to enable Belgian National calls, I had to set the ZAP trunk to remove the leading 0 prior to passing the number to the PSTN.

Does anyone have any experience of setting up Asterisk in Belgium with an ISDN trunk who can suggest what I should be passing to the trunk to enable International Calls and the Directory Enquiries numbers?


D I finally found out what the problem was - Belgacom (the Belgian PSTN) needs to have the “Type of Number” set on the ISDN channel. To make international calls, it needs to be set to “International” or “Unknown”. Because I was also having problems with National Special numbers (like Directory Enquiries), I elected to set the Type of Number to “Unknown”. International and Special numbers now worked, but I had to re-instate the leading 0 for National numbers.

the setting is in zapata.conf and reads



I have the same problem with not being able to dial out internationally because whenever we dial the numbers it shows up as a national call. I’ve entered the line:


in the zapata.conf but I still cannot dial out internationally. Is that the only way to set the “Type of Number” to “International” or “Unknown”?