Asterisk randomly restart - Error

Hello guys,

This week the asterisk restarted 2 times out of nowhere, I found the following error in /var/log/message:Aug 2 15:16:04 kernel: traps: asterisk[28881] general protection ip:7efe449efb67 sp:7efd4348bab8 error:0 in[7efe448a9000+1c3000]

Someone has already gone through this, help is welcome

Back when I was doing the BSD FAQ, we ran into a problem like this, and the advice I’ve given people on it since has worked well. In the NetBSD project, there’s a bootable RAM checker that you can download, install, and boot into that will check all of the CPU and RAM functions.

Every system I’ve had this problem with (all three) have popped positive with the RAM checker. Two were bad RAM sticks and one was a CPU/Sourthbridge (IIRC) error. Replacing the RAM on the first two solved it, the last one required a new Mobo.

Having said that, make sure your system is up-to-date and all of the latest software for your installation is there. My experience is that this isn’t sufficient to solve the problem, but it’s not a bad “next step”.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.