Asterisk Phonebook Pause

I’m trying to setup some speed dials in the *Phonebook, and can’t find a way to enter a pause. For instance I want to call a 800 number, and then dial an extension. An example would be 8009999999w1111, 8009999999#w1111 and multiple variations I’ve found online. Everything I’ve tried gives me an error ‘Please enter a valid Number’.

You can’t do this via the FreePBX web interface. You have to do a ‘database put’ from the Asterisk CLI.

Sorry, I did not know the syntax by heart. Should have told you to do a database show so you could see the keys.

Anyway please send a debug trace when the call fails.

Ok so I added the number with the database put(not too much info out there on how to) but now I get ‘cannot be completed as dialed’. Do I have to change the dial plan or something?

Sorry I’m such a noob, but by debug trace do you mean this?

== Using SIP RTP TOS bits 184 == Using SIP RTP CoS mark 5 -- Executing [789****#w107@from-internal:1] ResetCDR("SIP/107-000004cf", "") in new stack -- Executing [789****#w107@from-internal:2] NoCDR("SIP/107-000004cf", "") in new stack -- Executing [789****#w107@from-internal:3] Progress("SIP/107-000004cf", "") in new stack -- Executing [789****#w107@from-internal:4] Wait("SIP/107-000004cf", "1") in new stack -- Executing [789****#w107@from-internal:5] Progress("SIP/107-000004cf", "") in new stack -- Executing [789****#w107@from-internal:6] Playback("SIP/107-000004cf", "silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer") in new stack -- <SIP/107-000004cf> Playing 'silence/1.gsm' (language 'en') -- <SIP/107-000004cf> Playing 'cannot-complete-as-dialed.gsm' (language 'en') -- <SIP/107-000004cf> Playing 'check-number-dial-again.gsm' (language 'en') -- Executing [789****#w107@from-internal:7] Wait("SIP/107-000004cf", "1") in new stack -- Executing [789****#w107@from-internal:8] Congestion("SIP/107-000004cf", "20") in new stack [2011-08-19 14:43:10] WARNING[32757]: channel.c:4622 ast_prod: Prodding channel 'SIP/107-000004cf' failed == Spawn extension (from-internal, 789****#w107, 8) exited non-zero on 'SIP/107-000004cf' -- Executing [h@from-internal:1] Hangup("SIP/107-000004cf", "") in new stack == Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/107-000004cf'

I’ve also tried it without the #. I’m pretty sure it has to do with my outbound route, but I have no idea how to enter the pause. Oh and thanks for your help!!

W’s only work for DAHDI trunks.

SIP sends everything in an invite message, no concept of in band audio.

Oh, so there’s no way to enter a speed dial with a pause then? Well that stinks!

There is no way to do it with SIP trunks. It’s not a FreePBX issue.

You could write some custom code that would dial the channel then use the send dtmf application to transmit in channel DTMF.