Asterisk only sends voicemail emails if manually started by root

Hi all,

I am having a problem with a new install of my Asterisk Server.

EDIT I have a fresh install of AsteriskNOW 1.7.1 i386 using Asterisk 1.6.2.19 with FreePBX 2.9.0.7.

I can send emails perfectly fine using the Webmin Sendmail server. This works even if I send the emails through the user “asterisk”.

However, these voicemails are not being emailed when they are recorded as voicemails.

I noticed that if I run this command to kill asterisk:

killall asterisk

and then manually start asterisk as the user “root”

asterisk

Then when I call and leave a voicemail, the message sends perfectly via email.

So unless asterisk is started manually by the user “root”, the voicemail to email function is not working properly.

Does anyone know a fix for this issue? I have googled around but can’t seem to find the solution.

Thanks!

bump

You can’t really mean “[email protected]” Have you tried the FreePBX Distro, AsteriskNOW, Trixbox, or PBX In A Flash? I’ve used all except for Trixbox and had no trouble with emails (once Sendmail or Postfix were configured properly).

I am using AsteriskNOW 1.7.1.

I apologize for the misunderstanding. Not really sure why i wrote [email protected]

problem still exists

Thanks