Asterisk not start

Freepbx 2.5.2

I installed asterisk and the daemon run. Then i installed freepbx, asterisk works fine yet. When i reboot the system asterisk doesn’t start. And if i try to start it manually… nothing…
any idea?

need a debug log, status, etc

I think I have the same problem. I don’t have the debug output with me, but can post it when I get home tonight.

Here is what happens:

  1. Install Asterisk
    result: /etc/init.d/asterisk start & stop works fine

  2. Install FreePBX
    result: Looks fine at first in the web interface

  3. Stop & Start Asterisk (command line or reboot)
    result: Extension link is grayed out and Asterisk won’t start again

I installed Asterisk via Ubuntu’s Synaptic package manager. FreePBX doesn’t have permissions to read /etc/asterisk/asterisk.conf at default which makes me suspicious there could be some other permissions problem. Also, after completing my FreePBX configuration I’m not seeing evedence in the /etc/asterisk config files that they have actually been altered by FreePBX (granted I haven’t looked through all of them).

Hmm… did you run passwd-master?

Using default FreePBX admin security alone will not protect your system from a web attack and may compromise root access to your entire server, if you do not change the password, before connecting the PBX to the Internet. For this reason, we recommend that you log in as root and immediately run passwd-master. This establishes Apache .htaccess security on your FreePBX web interface. After running this conversion utility, you can only log into the FreePBX admin interface with the username maint and the password which you establish when you run the utility. ~snip~

Thanks for that advice. That didn’t make into the UbuntuServer install tutorial. Once I get this thing running I will try and improve it.

I would like to see your improvements, too. Thanks!

passwd-master doesn’t exist on my system - as in “-bash: passwd-master: command not found”

Nor can I find a script file anywhere on the computer with that name.

What should I do?


Here is my log of actions taken during the install.

  1. Install needed programs, letting package manager include dependencies
    asterisk, dahdi, libpri, asterisk-config, asterisk-mysql, asterisk-mp3

  2. Add system user and group asterisk (completed automatically by asterisk installation)

  3. Test asterisk start/stop

  4. Download FreePBX, copy to /usr/src and tar zxf

  5. mysql stuff

  6. Install FreePBX (/usr/src/freepbx_/install_amp)

everything is fine until here.

  1. Running passwd-master is reccommended immediately after install.
    I can’t find the command. Is this a php script?

  2. Stop/Start web interface

    bash$ sudo amportal start

    Permissions OK

    ulimit: 105: error setting limit (Operation not permitted)
    Asterisk ended with exit status 1
    Asterisk died with code 1.
    Automatically restarting Asterisk…repeating

is this a x_64 compatibility issue? start/stop works before freepbx is installed.

  1. Try web portal
    Error: /var/www/html/* is not world-readable
    Corrective Action: [TEMPORARILY just to see the web interface]: chmod -R a+rx /var/www/html

is the normal install procedure to change permissions on this?

now http://localhost/html/admin comes up, but with an error that the script can’t read /etc/asterisk/asterisk.conf (permissions)
should I chmod asterisk.conf? maybe chgrp?

Can you did you run update-fixes and update-scripts

That should make passwd-master appear.