Asterisk needs time to run


(Sami Hep) #1

recently i installed freepbx 15 distro on FW-7525C-015 with 16 GB CF (i knw it is a very low storage) and an 8 GB RAM. This device is not connected to the internet.

asterisk is taking more than 5 minutes in order to run.

extra note: when i type reboot in SSH it is taking a lot of time to do it as well.

i can not imagine what the problem is! so anyone could help ?

note: there is still no extensions defined ! nothing at all.


#2

Maybe the CF card is defective, or just too slow.


#3

16G is more than fine, what is an ‘FW-7525C-015’ ? If you have no Internet, then be careful with chan_sip and name resolution (you need to use /etc/hosts to resolve anything to a locally available IP or ‘noload’ it in /etcasterisk/modules.conf)


(Sami Hep) #4

@arielgrin How can i tell?


#5

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Sami Hep) #6

@dicko This is it:
https://www.lannerinc.com/products/telecom-datacenter-appliances/vcpe-ucpe-platforms/fw-7525

Thanks for the caution.
I am using chan_pjsip do i have to worry about anything?


#7

You need to worry about why it’s taking so long to start, First stop asterisk fwconsole stop then from a console asterisk -vvvc should show on the console what is hanging.


(Sami Hep) #8

Thank you i will try it and give u a feedback.

But what about this?? Did not get it?


#9

I posted against a reply to someone else, it is unlikely that you have a problem with the sd card except that sd cards are intrinsically problematic in the long run hosting an unmodified FreePBX/Asterisk system


(Sami Hep) #10

I tried it.
asterisk started quickly actually without any problems.
what should i check next?

but i realized fwconsole stop has stopped many other services as well.


(Sami Hep) #11

@dicko
hello my friend,
i guess i found out where things are getting slower.

i did fwconsole stop then fwconsole start.
at fwconsole start it was taking too long the set base permissions.

freepbx tells that if it is taking too long then i need to customize the chown command. with this link https://wiki.freepbx.org/display/fop/freepbx+chown+conf

i will see what i can do


(Lorne Gaetz) closed #12