Asterisk manager interface doesn't send full list as Response

Hello, i have a problem with AMI. (Asterisk 11)

If i directly connect to AMI on server and run command that generates List, i don’t get all of Events.

Let me show example.

When i run

Action: Sippeers

Response: Success
EventList: start
Message: Peer status list will follow

Event: PeerEntry
Channeltype: SIP
ObjectName: 100
ChanObjectType: peer
IPport: 54252
Dynamic: yes
AutoForcerport: no
Forcerport: yes
AutoComedia: no
Comedia: yes
VideoSupport: no
TextSupport: no
ACL: yes
Status: OK (108 ms)
RealtimeDevice: no


Event: PeerlistComplete
EventList: Complete
ListItems: 68

It says that there should by 68 items on list, but in reality it sends sometimes 66 or 67 items.

But if i ssh into server, login to AMI and run same command there i get all 68 items.

Same thing happens with Action: Agents. I get all 50 agents when i connect to server through ssh and run command there. But when i connect to port 5038 directly from my PC i get 48 or 49 agents.

Has anyone encountered this problem?

P.S. I ran tcpdump on server to see if all of the packages are send. And I see same thing. It sends only 66 items

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.