Asterisk Log Files WARNING[] file.c: No such format '���

Hi All

Call recording does not seem to working. This is for inbound outbound and internal calls.

FreePBX 2.10.1.3
Asterisk 10.10.0 built by root @ jenkins5.schmoozecom.net on a i686 running Linux on 2012-11-19 22:01:31 UTC

Any ideas?

Thanks

[2012-12-20 15:55:57] WARNING[25595]: file.c:1241 ast_writefile: No such format ‘Ãó’
– Executing [[email protected]:4] Set(“SIP/201-00000017”, “CDR(recordingfile)=out-XXXXXXXXXX5-201-20121220-155557-1356011757.23.WAV”) in new stack
[2012-12-20 15:55:57] ERROR[25595]: app_mixmonitor.c:517 mixmonitor_save_prep: Cannot open /var/spool/asterisk/monitor/2012/12/20/out-XXXXXXXXXX-201-20121220-155557-1356011757.23.Ãó

It’s an asterisk bug, we started trying to track this down, what version, etc. and then it got accidentally dropped. Will investigate some more if the latest version is still having this problem and dig around a bit with the Asterisk team as well.

quick testing status update on this …

It appears that 1.8.19 and 11.1 work fine but 10.11.0 is broken and I know it’s been broken since at least 10.9.0 and maybe earlier.

Still haven’t talked with anyone yet on the Asterisk team to see if they are aware of this on the 10 branch.

Thanks Philippe for your prompt assistance. It is greatly appreciated.

I’m having a similar problem with my FreePBX Distro the logs show the fallowing:

== Begin MixMonitor Recording SIP/520-00000020
[2012-12-30 17:22:45] WARNING[3451]: file.c:1241 ast_writefile: No such format ‘Ããw’
[2012-12-30 17:22:45] ERROR[3451]: app_mixmonitor.c:518 mixmonitor_save_prep: Cannot open /var/spool/asterisk/monitor/2012/12/30/exten-520-218-20121230-172236-1356909756.31.Ããw

Can sombody please help me or explain why im seeing this? All i can find in my
/var/spool/asterisk/monitor/2012/12/ is an empty folder of the current date.

PBX Firmware: 3.211.63-2

PBX Service Pack: 1.0.0.0

Asterisk 10.11.0 built by root @ jenkins5.schmoozecom.net on a i686 running Linux on 2012-12-18 22:52:02 UTC

Thanks!!

We have a ticket open with Digium on this and they responded with a patch that worked for them. The next time we build asterisk10 releases this patch will be included. We apologize for any inconvenience.

Is the patch from Digium available for download?

it’s in the DIgium ticket, I don’t recall the ticket number but you can check their ticket system, the patch is for app_mixmonitor so it shouldn’t be hard to find.

The issue that is opened with Digium can be found at https://issues.asterisk.org/jira/browse/ASTERISK-20834 along with the patch they supplied.

Our 10.11 RPMs have the patch in them so make sure you are running the latest Distro

The patch has to be applied to the source code files. You can’t patch a compiled object.

I have downloaded the patch but am nor sure how to install it. Please may someone advise.

Thanks to all for the assistance in this regard.

Currently running 10.9.0 (i686 version).

Instead of forklifting the entire config to new PBX version just to fix this silly bug, I extracted app_mixmonitor.so from the asterisk10-core-10.12.0-60_centos6.i686.rpm on the FreePBX-2.210.62-5-i386-Full-1359058538.iso and copied it over the broken module in: /usr/lib/asterisk/modules/. Problem solved.

IMPORTANT: This is a binary swapout, so if your versions are even slightly different, it probably won’t work.

I am having this issue with 4.211.64-6 running Asterisk 11.4.0.

4.211.64-7 was released which has Asterisk 11.5.1. Would the upgrade fix it, is there a fix other than an upgrade?

[2013-09-20 13:12:53] WARNING[11101][C-00000039] file.c: Unable to open file /var/spool/asterisk/monitor/2013/09/20/file.wav: No such file or directory
[2013-09-20 13:12:53] ERROR[11101][C-00000039] app_mixmonitor.c: Cannot open /var/spool/asterisk/monitor/2013/09/20/file.wav

My issue was something different, please disregard.

I had backed up /var/spool/asterisk/monitor from a system we are migrating off of and restored it to this new system via WinSCP as root so the ownership was set to root, I changed to asterisk and it works now.

chown -R asterisk:asterisk /var/spool/asterisk/monitor/