Asterisk Info version doesn't match with asterisk -r version

Asterisk info indicates 18.9 which was the version before I ran asterisk-version-switch

After I ran the asterisk-version-switch I see asterisk 18.16 if I run asterisk -r but Asterisk info still shows 18.9

Did I actually switch?

Can you try restarting?

fwconsole restart
1 Like

I’ll give that a shot when the system is less busy. In the meantime which is the actual asterisk version being used by the system right now, 18.9 or 18.16? After the upgrade to asterisk 18.9 my queue logs were not being populated so I’m hoping the move to 18.16 fixes that.

If Asterisk hasn’t restarted, it will be running the old version. If you have full logs back far enough look at those to see when it was last started. I think that will give version as well.

The following may work if the file name is looked up when referenced, but not if it is cached with the other information:

At a Linux shell prompt, issue:

head -5 /proc/$( pidof asterisk )/maps

If the first few lines end with something that doesn’t look like /usr/sbin/asterisk, you are probably using the old version. If it does look like that the result is inconclusive, because of the possibility that the information was cached.

This is a very low impact, read-only, operation, so safe on a running system.

If $( pidof asterisk ) doesn’t work properly replace it by the PID from a ps or top listing.

I’m assuming the installer does copy and rename, and therefore the underlying files is replaced, rather than overwritten.

1 Like
00400000-00715000 r-xp 00000000 09:7d 538756827                          /usr/sbin/asterisk
00915000-00916000 r--p 00315000 09:7d 538756827                          /usr/sbin/asterisk
00916000-0093e000 rw-p 00316000 09:7d 538756827                          /usr/sbin/asterisk
0093e000-00952000 rw-p 00000000 00:00 0
00e7f000-054e6000 rw-p 00000000 00:00 0                                  [heap]

Run asterisk -r and the banner will show you the asterisk version you have just run and the asterisk version you have connected to.

# asterisk -r
Asterisk 18.16.0, Copyright (C) 1999 - 2022, Sangoma Technologies Corporation and others.
...
Connected to Asterisk 18.16.0 currently running on x (pid = 22987)

If you ran a yum update and replaced the binaries without restarting asterisk, the version at top will be newer than the version at bottom.

Asterisk 18.16.0, Copyright (C) 1999 - 2022, Sangoma Technologies Corporation and others.
Created by Mark Spencer <[email protected]>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
=========================================================================
Connected to Asterisk 18.16.0 currently running on zulu (pid = 10790)

Perhaps I’m not very smart and the 18.9 is cached on the Asterisk info page.

Cleared cached and 18.16 shows on Asterisk Info. Now to figure out why the upgrade to Asterisk 18 stopped info from flowing into my queue logfiles…

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.