Asterisk fails to log in after changing admin pass in web GUI

After I change the password on a fresh installation of FreePBX 2.11 from the default ‘amp111’ to our company’s designated password for the PBX, the Asterisk 11.10 CLI throws an error every couple seconds:
NOTICE[13621] manager.c: failed to authenticate as ‘admin’

I tried ‘amportal restart’ and ‘service httpd restart’, updating manager.conf and (apparently this is legacy) amportal.conf, and anything else I could think of.

What are my options?

manager.conf is not legacy, where did you change the password in FreePBX?

You do realize this has nothing to do with logging on to FreePBX and is a password used to authenticate to the Asterisk API? That API should not be exposed to the Internet so I am wondering what goal you are trying to accomplish?

Sorry, I meant to imply that the amportal.conf was legacy; I am aware that manager.conf is not.

I changed the password under Settings > Advanced Settings > Asterisk Manager

I am trying to change the password from default for security, and to match the company’s settings from our old PBX server.

You don’t and shouldn’t ever change that password. It’s a loopback meaning only can connect to the interface using that password.

I see…

Thanks for the responses =) That explains it…but then, out of curiosity, why this message:
Warning Default Asterisk Manager Password Used
You are using the default Asterisk Manager password that is widely known, you should set a secure password
Added 14 hours, 7 minutes ago

That message has been in a long time. It is from the old Asterisk Management Portal days.

As far as the motivations, I have no idea.

You can change it if you feel that someone is going to try and connect to your AMI API (I am interested, what did you think this was for?) from your LAN.

Anyway, you may encounter a race condition, best to do an amportal stop. Make changes to FreePBX db as you did in Advanced Settings module, then stop asterisk/FreePBX and edit /etc/asterisk/manager.conf to match your settings. Then fire it all up and you should be fine.

I’m all set now, thanks SkyKing!

I have no idea; I was basically told “We have nobody else that has the capacity to do this right now, so take this broken PBX and replace it with identical settings without reproducing the break”. So, we’re running FPBX on an EC2 instance and I’m trying to copy over a bunch of stuff like custom dialplans and the like, and because the old server was 2.10/1.8 to the new one’s 2.11/11.10, a lot of things are broken. One of the settings that I took the default on was this password and we used a different one on the previous server; I was just trying to replicate that.

My experience with PBX systems prior to this was essentially nil. So far, I’ve got everything working (or so it appears) except for a few errors that the Asterisk CLI is throwing at me. Would it be acceptable to create a new thread HERE with Asterisk issues, or should I stick to my thread on their forums? I ask because the ‘help’ I got was “Go learn what you’re doing first, then come back and ask for help, or go hire someone from the jobs board” >.<

That was one persons comment although the Asterisk board is “rougher” that ours.

I have said that to people, usually reserved for those who have not tried and are just looking for someone to fix their issues without having a hand in it.

Certainly start a new thread, if your questions are specific I am sure that somebody will help.

What is the worst that can happen? Give it a go.