Asterisk Fails after module update

Hi,
Today after the module update, asterisk wont start.

[2011-05-07 12:31:34] NOTICE[5315]: manager.c:2297 authenticate: 127.0.0.1 failed to authenticate as ‘admin’
[2011-05-07 12:31:36] NOTICE[5320]: manager.c:2297 authenticate: 127.0.0.1 failed to authenticate as ‘admin’

The password is the same in amportal.conf and manager.conf.

[[email protected] /]# telnet 127.0.0.1 5038
Trying 127.0.0.1…
Connected to localhost.localdomain (127.0.0.1).
Escape character is ‘^]’.
Asterisk Call Manager/1.1
Action: Login
Username: admin
secret: VtD3NfUK0vjN

Response: Success
Message: Authentication accepted

Event: FullyBooted
Privilege: system,all
Status: Fully Booted

Any suggestions?

thanks

Andrea

Did you figure this out? How did you upgrade your modules and are you sure this is on the FreePBX Distro that you are having this issue. If so what version of the distro are you using?

Hi Tony,

Thank you for your reply

Now the problem has been solved.

F.I.

First step
I have installed freepbx distro 1.8.
Updated
restored backup from another freepbx
After restore, asterisk fails

Second Step
I have re-installed freepbx distro 1.8.
Updated
restored backup from another freepbx
After restore, asterisk works

I don’t know …

I had a perfect system until yesterday, but then I had to go and upgrade FreePBX to 2.9, and then try to upgrade fop to fop 2.2, and somewhere along the way I must have messed something up. Unfortuantely I am not sure which change broke my server, so I am trying to troubleshoot two issues at once.

My system:

PIAF: 1.7.5.6.2 (iso downloaded 5/22/2011)
FreePBX: 2.9.0.7
Asterisk: 1.8.4.1
OS: CentOS 5.6
Kernel Ver: 2.6.18-238.9.1.e15 - 32 Bit

Issue 1= FreePBX upgrade to 2.9:
After upgrading FreePBX to 2.9, I saw the notice stating “You are running with the default, well-known Asterisk Manager Password”. I tried to enter a new password in ConfigEdit=> /etc/amportal.conf but it wouldn’t save. I gave up trying to figure out the problem and moved on to upgrading my fop to fop 2.2.

Issue 2= FOP upgrade to 2.2:
I followed the fop2 install instructions from: http://pbxinaflash.com/forum/showthread.php?t=6890&page=2
While following the instructions, I learned that the asterisk manager password was placed in at least two locations: /etc/amportal.conf and /etc/asterisk/manager.conf.
The instructions say to make sure the passwords are the same - so I took it upon myself to go ahead and change the passwords (identical, of course, just not the default amp111).
I used Putty to do this. I followed the rest of the instructions. The only mistake I made was failing to catch the introduction of the instructions:
“This upgrade applies to the ks16 or ks16alt install of 32 bit PiaF. Asterisk 1.6.0.6, 1.6.1.1, 1.6.2.0, 1.6.2.6 with FreePBX 2.5.2.2 and 2.6.0.2, PiaF Purple, Asterisk 1.8, FreePBX 2.8.10.”
(No mention of FreePBX 2.9 - not sure if this is a problem or not)

When finished, I ran:
/usr/local/fop2/fop2_server --test
It responded with the expected:
Flash Operator Panel 2 - No valid license found. Demo Mode
Connection to manager OK!

I thought everything was working great, but when I go back to the GUI FreePBX, the dashboard shows:

Asterisk=Error
Op Panel=Warn - switches back and forth from Warn to OK
MySql=OK
Web Server=Error - switches back and forth from Error to OK
SSH=OK

Additionally, the FreePBX notice I get is:

retrieve_conf failed, config not applied
(Reload failed because retrieve_conf encountered an error: 1)
(freepbx.RCONFFAIL)
Ironically, I no longer get the notice about the default password being used :slight_smile:

I check the Asterisk Logfiles, and see these two messages that seem to be relevant:
[2011-06-14 14:27:03] VERBOSE[22475] manager.c: == Connect attempt from ‘127.0.0.1’ unable to authenticate
[2011-06-14 14:28:53] NOTICE[22526] manager.c: 127.0.0.1 failed to authenticate as ‘admin’

My users (5 WINXP PRO SP2 workstations using softphones) are still able to make and receive calls, but the quality is not great. I am locked out of many FreePBX modules.

I have tried to reverse everything I changed when upgrading FOP2, I have tried to change the manager password back to amp111, but I cannot fix this issue on my own.
Can anyone lend me some help?
Thanks
Ethan Case

In FreePBX 2.9 you use the advanced settings module (as noted in the top of amportal.conf) to change the Asterisk Manager username and account.

Yes, sorry I forgot to mention that I also changed the password in Advanced Settings when I was trying to reverse everything back to a working condition. Still no good.