Asterisk does not know version

trying to upgrade two modules (Asterisk Info and Asterisk CLI) from 2.6 to 2.7, but i get this error:

[code]Asterisk CLI cannot be upgraded:

  • Requires engine asterisk, you have: ERROR-UNABLE-TO-PARSE 0[/code]

it appears that asterisk does not know what version it is running:

[code]# asterisk -V

asterisk -r

Asterisk , Copyright © 1999 - 2008 Digium, Inc. and others.

asterisk*CLI> show version
Asterisk built by root @ on a i686 running Linux on 2009-10-21 21:54:49 UTC[/code]

but it does have a version file with the correct build:

# cat /etc/asterisk/version Asterisk

does anyone know how to fix this?


i previously posted about a similar issue (cf., and no one replied …

really? no one has a clue about this?

If we should be picky about Asterisk here is my advice, download, all versions after that has a broken dtmf implementation that does this:

Outside call into Asterisk, extension answers, when extension press any key on the phone it will not reach the caller. All outgoing calls work with dtmf.

This means that if you have a door phone that requires you to press, for example, 5 to open the door lock it wont work.

It is fixed in 1.4.31 that is on RC right now.

Lack of details.

Have you installed Asterisk by yourself or do you use a distro?

mikael - thanks for replying! :slight_smile:

#uname -a
Linux asterisk.localhost 2.6.18-92.1.10.el5 #1 SMP Tue Aug 5 07:41:53 EDT 2008 i686 i686 i386 GNU/Linux

originally installed asterisk 1.2 via freepbx iso (i think)

upgraded to asterisk 1.4 by downloading source from digium, running configure and make upgrade

let me know what additional info i can provide.


Reinstall Asterisk by:

cd "directory with zaptel or dahdi"
make clean
make install

cd "directory with Asterisk source"
make clean
make install

cd "directory for asterisk-addons"
make clean
./configure (maybe not needed)
make install


just to clarify … should i download the latest tarball from digium, unzip it, and then make clean, configure, make, and make install?

do i need to do that 3x as you outlined above?

thanks for the quick reply :slight_smile:

Hmm, there was a formatting error in my post, it is now corrected. is rather old, I would have downloaded the latest 1.4 together with latest addons and dahdi

actually, don’t download the latest 1.4, it has some serious issues in it. (iirc - that would be 1.4.30).

Something around 1.4.29 is probably safe.

thx guys! i’ll report back shortly after i have done the above.

appreciate it :wink:

found the asterisk … looks like add-ons latest version is 1.4.11 (is that ok?) … but the dahdi is 2.3.0 (is that ok?) … just want to make sure i get the right versions here.

also noticed that asterisk 1.6 is looking more and more mature. does freepbx 2.7 support asterisk 1.6 or should we wait to bump to asterisk 1.6 after freepbx 3.0 comes out?

thanks so much for your help … looking forward to getting this resolved :wink:


Oh, I thought this was solved.
Asterisk is OK to use.
Add-ons 1.4.11 is OK to use.
Dahdi is 2.3.0, I would download dahdi-linux-complete-2.3.0+2.3.0.tar.gz

:slight_smile: and there was much rejoicing!

problem 100% solved.

thanks again for your help!