Asterisk disconnects from provider after update

I am running FreePBX 15.0.17.32, and I am quite happy with it. One problem that vexes me a bit is that occasionally the system hangs after an (automatic) update. It seems that Asterisk loses connection to the SIP provider and then never reconnects. A restart of the computer has fixed this every time.
But it leaves the system unresponsive until I find out that this has happened. Is there a way to tell the system: Do a restart after a successful update"?
The other option would be to restart the system every day, but I am afraid that if the update and the restart happen at the same time (restart through crontab), I would end up with an inoperable system.
Any suggestions?
Thanks.

What (if anything) appears in the Asterisk log for the failing registration attempts?
When the failure occurs, can you still get to the FreePBX GUI? If so, what does Reports -> Asterisk Info -> Registries show?

Have you tried smaller clubs, such as restarting Asterisk or fwconsole restart?

Completely? I would expect if only the registration were lost, that calls between extensions would still work.

Can you cause this problem at will by forcing a module update?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.