Asterisk Constantly Restarting After Detect Network Settings

I followed the guide to install FreePBX 13 on CentOS 7 at

All went well and I had the system up and running. I then went about configuring my system until I clicked the “Detect Network Settings” in the “SIP Settings/General SIP Settings”. Once I did that I suddenly got a “Can Not Connect to Asterisk” at the top right. I can see that Asterisk is constantly restarting every 4 seconds.

Checking the /var/log/asterisk/full log I don’t see anything out of the ordinary aside from it getting spammed with the asterisk restart.

I also checked the /var/log/asterisk/freepbx.log and It just keeps saying “[CRITICAL] (admin/bootstrap.php:270) - Connection attmempt to AMI failed” every couple of minutes.

I completely reinstalled a second time and did nothing else then go to this button and click on it and got the same issue.

If I keep bringing up ps aux I can see asterisk will run for a second or two and then disappear.

What does this “Detect Network Settings” button do? I’ve tried both filling out this information correctly for both external and local networks and clearing them without any difference.

I’ll also say this may be PJSIP related. As the second time I disabled chan_sip and these fields never got populated after pressing this button. The first time the fields did get populated when I had chan_sip still active but it still had the same result of causing Asterisk to constantly respawn.

Any suggestions? I have logging maxed out on all the logs but nothing is coming up in there.

I’ve narrowed this down to an issue with enabling TLS.

Please see my new post… Enabling TLS Crashes Asterisk.

Apologies for the multiple posts. Just took a long time to rebuild FreePBX each time to test things one at a time to figure out the actual cause.