Asterisk constantly crashing


#30

rebooted… error still happening


(Itzik) #31

Then try first:

fwconsole stop
yum update -y
reboot

Start asterisk after boot (give it two three minutes to start on it’s own):

fwconsoel start

(Itzik) #32

They provide: https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-Backtraces(Segfaults/CoreDumps/AsteriskCrashing)


#33

installed the sangoma-devel and debug packages but not sure what to do after that… instructions are kinda all over the place on that pages…

sorry… a bit confused on how to upload the info


(TheJames) #34

I think @lgaetz is correct it may be best to open a ticket. I may even passively poke @mdavenport to see if he pokes his head in…

Ultimately one of your libraries is mismatched. You have jumped through the hoops so I will assume you are using distro builds of all of the asterisk packages. Perhaps you built a library or installed a 3rd party RPM for something like libssl or one of the other dependent libraries. Something is not “binary compatible” with the asterisk build.

Do you have any 3ed party repos?
Have you (or anyone) compiled any libraries?

ldd /usr/lib64/asterisk/modules/res_digium_phone.so

You can see the linked libraries with ^^^


#35

nothing 3rd party… this is a vanilla distro system


#36

Is it possible you have a hardware specific (often memory related) problem ? ( the coredump always seem to happen after accessing similar mapped address space)

https://linuxconfig.org/installation-of-memtest-ram-memory-test-tool-on-redhat-7-linux

boot into it and wait a few hours . . .


#37

unfortunately… ERROR: memtest86+ does not support EFI platforms.


#38

Coincidence ?

Digium Phone App Totally Broke


#39

I think not… asterisk crashes when the phones try to connect…


#40

Then obviously unrelated .


#41

sarcasm?


#42

No, I am just not a particular believer in ‘coincidences’ being unrelated.

Did you check your memory’s integrity yet ? It would be one thing to check off the list .


#43

can’t… see post above


#44

Boot a “recovery iso” that can bypass uefi perhaps ? (it might be a bios thing needed . . .)


#45

at this point I’m installing the ISO on a usb stick and I’m going to reload from scratch and restore a backup.


#46

On fresh installs, I always add a ‘root kit’ detector as soon as possible, you never know . . .


(Canada) #47

I had this exact same issue today, however on another platform. My client is running FreePBX 15 on Sangoma Linux 7 and this morning I got the call the phones were down. The only way I could get the PBX back online was to run yum erase asterisk16-res_digium_phone which disabled the DPMA module. When I tried to re-install the module, asterisk again started to crash every few seconds with the same segfault error. Thankfully I am able run this PBX without the Digium Module and failing finding a solution, I may have to do a fresh install as well.


(Lorne Gaetz) #48

(Canada) #49

Thank you for informing us about the downgrade. This resolved the issue on my PBX as well. From an uninstalled state, I ran yum install asterisk16-res_digium_phone which installed version 3.6.5.1 and then without an asterisk restart I immediately ran yum downgrade asterisk16-res_digium_phone which installed version 3.6.3.2 then finally ran fwconsole reload

This restored the Digium Module to a good working state with no segfault crashes.