Asterisk CLI "no output performed"

asterisk
Tags: #<Tag:0x00007f7026ee22d8>

(Tom) #1

I am in charge of FreePBX at my office, but don’t have a lot of coding experience. I have been getting this error on my dashboard for awhile now, but it never seemed to be affecting anything:

Module_admin listonline error

Now my firewall is not running and my office manager is getting flooded with emails about intrusion detections. Not sure if the two are related.

I tried to follow some help from other forums, but when I try to access commands like from Asterisk CLI, but I get “no output performed” responses instead of what people are saying I should get. I work remotely due to COVID, so I don’t have access to the Asterisk machine, so I am trying to solve this problem through FreePBX.

Any ideas?


(Dave Burgess) #2

This is normally a response from the job that checks to see if you need to update your modules. What version of FreePBX are you using?

This is almost assuredly a different problem. Have you tried restarting the firewall?

Where are the emails coming from?

That’s a new one. I’ve never seen that message from FreePBX before.

That’s a worrisome statement, since FreePBX runs on the Asterisk machine. How are you connecting to the FreePBX GUI?


(Tom) #3

Thanks for responding! To answer your 3 questions:

  1. I am running version 13 of FreePBX
  2. I tried resetting the firewall, but it won’t turn on still. The email I get is this: “The IP 122.194.229.122 has just been banned by Fail2Ban after 3 attempts against SSH on (my domain)”
  3. What I meant by I don’t have access is that I work remotely right now to Covid so I just remote into my work computer and use the ip address of FreePBX to access the GUI from my browser on that computer.

(Dave Burgess) #4

OK - I have a couple of suggestions.

  1. There’s an fwconsole command to trust your IP through the console.
  2. You might want to plan on an upgrade to the newer version of FreePBX. The firewall in it’s earliest versions had a lot of problems, so make sure you are as up-to-date as you can be.
  3. Is 122.194.229.122 your IP Address? If so, three failed login attempts should lock you out. If not, then I don’t see the problem. There are two different solutions to this problem. The first is to make sure you don’t hose the password. The second is to add that address as a trusted network in your PBX Firewall.

You can easily SSH into the box and have almost all the same access that you would from the office - putting a CD in the drive is the only difference. Log in as ‘root’ and use your root password to log into the box, then you can use the command line tools to do your thing.


#5

(but can always loopmount an iso image of the CD)