"Asterisk appears to be running as asterisk." Home folder exists


#1

“Asterisk appears to be running as asterisk.” message appears at the last step of installing FreePBX. On another post here there was a similar problem where the solution was to create the missing home folder for the service account.

I had already done that though;


So, I’m a little clueless what to do next. Accidentally I discovered that httpd was running already so I disabled it since it would at the very least be occupying the port, I then rebooted but it made no difference.

A few days ago I installed the FreePBX distro while waiting for some huge files to move and FreePBX’s official distro had a similar issue where Asterisk wouldn’t start but that’s just it, it needed to be started.

I created the /etc/systemd/system/freepbx.service file in advance, it hasn’t been enabled. Basically all that’s left is to run the FreePBX install process.

How can I start Asterisk correctly so the install process doesn’t fail to run?

Thanks,