Asterisk 13, FreePBX 13 on Ubuntu 16.04.2 ARM Devices (orangepiPC) {PROBLEM}

Hi guys
i am trying to install asterisk and freepbx on ubuntiu 16.04 using this guide
https://drive.google.com/file/d/0B8w4ZQV13bCSNDMzNFFmTWVSVVE/edit1

i tried almost 100 times and everytime it returned me with errors. i got errors at the last part when i run this command “./start_asterisk start”

[email protected]:/usr/src/freepbx# ./start_asterisk start

STARTING ASTERISK
./start_asterisk: line 45: /usr/sbin/safe_asterisk: No such file or directory
Asterisk Started

and another error i get is when i run this command "./install –n"
[email protected]:/usr/src/freepbx# ./install –n

[RuntimeException]
Too many arguments.

install [–dbengine="…"] [–dbname="…"] [–cdrdbname="…"] [–dbuser=". [–dbpass="…"] [–user="…"] [–group="…"] [–dev-links] [–webroot=". [–astetcdir="…"] [–astmoddir="…"] [–astvarlibdir="…"] [–astagidir."] [–astspooldir="…"] [–astrundir="…"] [–astlogdir="…"] [–ampbin="] [–ampsbin="…"] [–ampcgibin="…"] [–ampplayback="…"] [-r|–rootdb]|–force]

please help me what should i do ??/
any help would be apprciated
best regards

maybe the different platform, why you donot follow the offical link:https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+Debian+8.8

1 Like

hi and thanks for the reply…
i just followed the link u gave me and i got the same error
i get this:
[email protected]:/usr/src/freepbx# ./start_asterisk start

STARTING ASTERISK
./start_asterisk: line 45: /usr/sbin/safe_asterisk: No such file or directory
Asterisk Started

and this:
[email protected]:/usr/src/freepbx# ./install -n
Assuming you are Database Root
Checking if SELinux is enabled…Its not (good)!
Reading /etc/asterisk/asterisk.conf…Done
Checking if Asterisk is running and we can talk to it as the ‘asterisk’ user…Error!
Error communicating with Asterisk. Ensure that Asterisk is properly installed and running as the asterisk user
Asterisk does not appear to be running
Try starting Asterisk with the ‘./start_asterisk start’ command in this directory

please please help me :frowning:

I think you are missing some file already such as start_asterisk file. Can you try copy the file to the dire?

1 Like

hi
thanks for the help
i am new to linux , how can i copy the file ? which file ? is there any step by step command ?
thanks

please check wbat is the file at line 45:
TARTING ASTERISK
./start_asterisk: line 45: /usr/sbin/safe_asterisk: No such file or directory
[/quote]

1 Like

Doing a custom asterisk and FreePBX install on an unsupported platform with no Linux experience is deep magic. I’ve been doing this for years, and it’s still a daunting proposition. You might want to consider lowering your sights a little and maybe implement the Distro version on more common hardware.

The fact that you don’t even know how to use a copy command from the Linux prompt means that the rest of the even more complicated stuff might be out of your reach right now.

2 Likes

You may want to use something like http://www.raspberry-asterisk.org/ which does the heavy lifting

2 Likes

Hi my friend and thanks for the help
I just wanted to run 3cx on my orangepi pc but after thousands of tries I figured out that 3cx ( famous pbx client and server app) only runs on x64 bit devices. I tried to run alternative app on my orangepi so i found this freepbx runs on 32bit devices.
I really executed all commands according to the guide but it came with no success.
I have a VOIP account that only runs on my IP so i need to install a forwarding application on my orangepi so i can use my VOIP on my cellphone and with any IP. I really need help with this.
IS there any thing i can do with this orangepi ?? Where can i obtain Distro version ? Any alternative ? any suggestion ??
that would be greatfull
best of king regards

hi my dear friend thanks for the concern and help
will this image work on my Orangepi PC ??
thanks :X

anyone help me please…

I doubt this will install on an Orangepi PC without some modifications, but it may give you some ideas as to what needs to be done:

https://www.dslreports.com/forum/r30661088-PBX-FreePBX-for-the-Raspberry-Pi