Asterisk 13.23 PBX failed to create 2020 folder in /var/spool/asterisk/monitoring/ for Call Recordings


(Trevlyng) #1

Hello All,

We use the Call Recordings and this morning Asterisk was failing to write the call recording files, checking Asterisk we got the message:

[2020-01-02 09:05:00] WARNING[29123][C-000266c8] file.c: Unable to open file /var/spool/asterisk/monitor/2020/01/02/q-500-6036777863-20200102-090459-1577973899.8005911.WAV: No such file or directory
[2020-01-02 09:05:00] ERROR[29123][C-000266c8] app_mixmonitor.c: Cannot open /var/spool/asterisk/monitor/2020/01/02/q-500-6036777863-20200102-090459-1577973899.8005911.WAV

Looking further into it we realized that there was no 2020 directory within /var/spool/asterisk/monitoring/ hence the title. After manually creating a 2020 directory and performing a “chown” to make sure it had the same permissions/owner/group Asterisk was able to auto-generate the month and day directories (e.g. /var/spool/asterisk/monitoring/2020/01/02) and everything is working as intended now. Looking in the logs I can’t seem to find anything specifically relating to attempting to create the directory or anything like that. Has anyone come across this before? Thanks!


#2

Very strange. I just tried to reproduce this, but my test systems were able to create the 2020 folder(and subdirectories) just fine. Do you know which version of the callrecording module you’re using?


(TheJames) #3

There is a chance on his system that folder may not have been owned by asterisk. In that case a chown would have fixed it. This is a guess as that data wasn’t provided above.


(Trevlyng) #4

We are currently running Call Recording 13.0.11.11, and for that folder (/var/spool/asterisk/monitor) I double checked and it was in fact not owned by asterisk but by root so we’ve performed a chown and hopefully that will prevent this from happening in the future, thank you!


(TheJames) #5

on the upside it can only happen once a year :wink:


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.