Asterisk 1.4.15 works partially with FreePBX

I have asterisk 1.4.14 and everything is working fine. However if I upgrade to 1.4.15 the extensions using a PAP2 stop working, I get a registry, peers the system is up shows all the extensions but when I dial I get a fast busy signal, none of the features work. Now on an additional extension using an Aastra 480i I have no problems at all. Then I go back and install 1.4.14 again and everything is back to normal. Just wonder if anyone has tried this versions or reported any problems. Is there a way I can test this situation to see what’s causing the problem?

Thank you.

I just installed a new server using Asterisk 1.4.15. I noticed that the “Voicemail” section was missing from the Features page. Dialing *97 or *98 from the phone to access voicemail resulted in a “Feature not available on this line” message. Dialing * and the extension did allow me to leave a voicemail. The voicemail showed up on the recordings page. Just *97 and *98 were missing. I downgraded to Asterisk 1.4.14, re-ran the 'install_amp" script, and everything is back to normal.

that does not make a lot of sense, the voicemail module does not care what version of asterisk is running under it. I suspect you had some how disabled or removed the voicemail module in the process. Take a closer look, disabling the voicemail module would still have allowed direct calls to voicemail to work.

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

Well, it sounds silly, but I had similar problems when upgraded to 1.4.15 from 1.4.13
After scratching my head and googling for few hours I finally found the cause for all these issues!

You should put
srvlookup=no into [general] section of sip.conf.

Works well since.

Check this on the digium site:

Looks like they changed default behaviour for DNS lookups beginning version 1.4.14
It’s defenetly there in 1.4.15
I have never had verison 1.4.14 installed so can’t confirm…

If there is an issue that can be solved by adding some information to a sip.conf file automatically based on Asterisk version, please articulate details in a bug ticket so that we can conditionally include it based on Asterisk version. Please provide details of the issue, what is needed, why, and any pointers to supporting material for us to review. Thanks!

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

I’m sure the issues are not FreePBX. Theese are Asterisk issues with the new 1.4.15 and in my case I’m sure something has changed with the g729 codecs. Yesterday I included other codecs and was able to communicate but have not test it further. I will also try the srvlookup and test the results. Thanks

Asterisk 1.4.14 on CentOS 4.5 dual pentium4

It is an asterisk issue with the g729 codec, I’m using their v.33 and there is a problem still. Meanwhile, I’ll set back to 1.4.14 and wait to see what happens. Thanks everyone.

Asterisk 1.4.14 on CentOS 4.5 dual pentium4

I just installed FreePBX and found that the voicemail access features are missing!

Does anyone know if there’s a way to get them back?