Asteridex not ringing extension

Hi all,

My first post after setting up my first hosted PIAF (PBX in a Flash Green with FreePBX 2.11) on rentpbx.

Everything’s gone well except for my latest attempt to install Asteridex. I’ve followed the great instructions at: Everything went smoothly and the web interface and database for Asteridex is all up and running.

However, whenever I click a contact it says my extension is ringing when it isn’t meaning it’s not possible to make a call! I’ve spent hours on it but just can’t figure it out and as I’m a newbie my knowledge is rather limited I’ve searched extensively on the forum but could only find a few people with similar problems but no solutions…

Any help would be greatly appreciated!!


I would think you would be better off asking for help over at the PBXIAF site.

The major stumbling block to successful outbound calls with AsteriDex usually is a problem in the [custom-callboth] context in extensions_custom.conf. Be sure the default setup works for the types of calls you are placing. For example, if you’re outside the U.S., the default setup won’t work. Also, earlier releases required that you specify the actual trunk number to be used for the outbound calls. See the old commented line below for an example. We’ve now replaced this with a more generic setup that looks like this:

[custom-callboth] exten => _1NXXNXXXXXX,1,Wait(1) exten => _1NXXNXXXXXX,n,Background(pls-wait-connect-call) ;exten => _1NXXNXXXXXX,n,Macro(dialout-trunk,10,${EXTEN},) exten => _1NXXNXXXXXX,n,Goto(outbound-allroutes,${EXTEN},1) exten => _1NXXNXXXXXX,n,Macro(outisbusy) exten => _NXXNXXXXXX,1,Wait(1) exten => _NXXNXXXXXX,n,Background(pls-wait-connect-call) exten => _NXXNXXXXXX,n,Goto(outbound-allroutes,${EXTEN},1) exten => _NXXNXXXXXX,n,Macro(outisbusy)

Thanks a lot! You were absolutely spot on :slight_smile:

There was some kind of minor issue with the installation but after a quick re-install and some tweaks to the context you mentioned it is working. As I’m mainly dialling non-US numbers I set it as follows:

exten => _1XX.,1,Wait(1)
exten => _1XX.,2,Background(pls-wait-connect-call)
exten => _1XX.,3,Macro(dialout-trunk,1,${EXTEN},)
exten => _1XX.,4,Macro(outisbusy) ; No available circuits
exten => _XX.,1,Wait(1)
exten => _XX.,2,Background(pls-wait-connect-call)
exten => _XX.,3,Macro(dialout-trunk,1,${EXTEN},)
exten => _XX.,4,Macro(outisbusy) ; No available circuits

I think that’s suitable but was hoping to enhance it to route numbers dialled in a specific country (Cyprus for example 357) to route via a different trunk as it seems to only go via my main trunk (trunk 1) and doesn’t follow the normal outbound rules already setup.

Thanks again for taking the time to reply so quickly and thanks for all your work on PIAF…it’s made the daunting task of setting up my first PBX so much easier. :slight_smile:

Wow, check that out. By merely invoking the name of PBXIAF Ward descends upon the thread with a solution.