[ASK] Sending command that contain #

I need to send command that contain # to the trunks from my ip phone, but always get an error because freepbx terminate the command after # is pressed.

I need to send this: *1#*123#

Or if it cant be pressed directly from the phone, is it possible to create a script that sending the command to the trunk and display the result?

Thanks a lot!

Try this…

After dialing the special character, wait a second or two, then go along with your dialing. Seems to work here.


Thanks a lot, Bill, will try it tommorow.

is it possible to create a script that sending the command to the trunk and display the result? I dont think so because eachtime freePBX receive the # it will terminate the dialing. Is that correct?

Oh Yes…

Make sure the digit map in your particular telephone instrument is not blocking or otherwise modifying the numbers dialed, and, you might have to disable the “#” as the send command, but I don’t think that would be necessary in an overdial scenario.
Sorry for splitting this across two posts…byt for the first time in my life I hit the post tab prematurely (grin).


Hi Bill,

After dialing the special character, wait a second or two, then go along with your dialing. Seems to work here.

It’s not working this way :frowning:

Is there any solution for this? I really need this feature

What about the digitmap of the phone?

Hi Bill,
where should i search for the digitmap? on the phone setting page or in the freepbx?

thanks a lot for ur help :slight_smile:

On the phone itself. I usually just remove it completely.


Wont it break anything if we just remove it completely?

That is, of course, a consideration, but if it’s a question of something working or not working sometimes you have to make a decision on what you have to do.

In the real world, though, I’ll bet most users don’t craft a particular telephone dial plan specifically for their system. They’ll use the default or wipe it out completely, using the send, dial, or “#” key to initiate the call. Most of my users use on-hook dialing…they dial the number and then hit the speaker key and wait until they get an answer.

I’ve seen the special key problem come up a bunch of times, even back in the AAH days, but no one has come up with a definitive answer for it. Probably because there is none. There could be numerous causes, even going back to signalling issues on the trunk.




I’d also try to call a number you can listen to (cell phone, etc), and while listening, punch the numbers and see what you here. It also seems to me that I remember somewhere in the deep dark past that double punching a number made this work. That is if you need a special character (* or #)hit it twice.


Removing the digit map from the phone will force users to have to press send.

A properly crafted dial plan in the phone is essential for happy users.

Personally I go nuts when a tech does not set the dial plan right. It’s just plain sloppy work. I don’t think it has anything to do with passing DTMF overdial. In that regard I have never had an issue and I use * and # on a daily basis to bypass cell greetings when I call people.

Back to my dialplan, here is my 2 cents. If you pickup the phone and receive dialtone with a properly crafted dial plan as soon as you dial an extension or an outside number the call is completed, no delay, nothing funky. It’s even more important on transfers that complete without an additional keystroke. To me it is professionalism, the system is not complete without a dial plan. This is one of the downsides of an open system. In a closed system the handsets are tightly coupled to the system dialplan.

Well, all of the philosophy being done, do you have any solution to the problem or at least a flow chart for troubleshooting?

How to troubleshoot:

[] What version Asterisk
] What version FreePBX
[] What kind of phones
] What kind of trunks
[*] Please post output of ‘feature show’

Thank you for trying to help for Bill and Skyking. Really appreciate it.

I try above solutions but nothing seems to work. I try also with analog phone + ATA that doesn’t end the call after “#” pressed, but still doesn’t work.

So here is the situation:
To make a outgoing call, I dial the number with prefix 1 to choose trunk 1, with prefix 2 to choose trunk 2. So if I want to call number 555555 then I press 1555555 and the system will dial 555555 through trunk 1.

Now I need to dial *1#888# through trunk 1, so I press: 11#*888#

Asterisk version
FreePBX version 2.8.1
IP Phone Yealink T20
The trunk is a fixed GSM machine (with a GSM card on the machine) --> this is a quick solution for adding phone line rather than apply the PSTN line from telco company.

Output of "features show"
Builtin Feature Default Current

Pickup *8 *8
Blind Transfer # ##
Attended Transfer *2
One Touch Monitor *1
Disconnect Call * **
Park Call
One Touch MixMonitor

Dynamic Feature Default Current


Feature Groups:


Call parking (Parking lot: default)

Parking extension : 700
Parking context : parkedcalls
Parked call extensions: 701-750
Parkingtime : 45000 ms
MusicOnHold class : default
Enabled : Yes