[ASK] Caller ID

Greeting for all members. I’m a new member here and a new user of Elastix :slight_smile:

When we have a inbound call, some extensions rings and those ringing phones display the caller ID. Then I pickup the call from my desk (my ext is not in a ring group) by pressing *8# the call redirect to me, but the caller ID doesn’t displayed on my phone. Is there anyway to get the caller ID displayed on my phone without put my extension in the ring group?

Sorry for my poor english but I hope everybody here undertand what I’m trying to say :smiley:

Thanks you very much!

It would be helpful to know what version of Asterisk you are using and what model phones. Asterisk 1.8 supports called party ID.

Finally, there is an reply. Thanks, Alan!!

I’m running Asterisk
The phone is Yealink T20. What is called party ID ?

Any clue how I can accomplish this would be very appreciated.


I’m tired receiving answers from my elastix “consultant” that keep telling me (almost) any “features” I want is not doable :frowning:

Google “Calling Party Identification” for an explanation.

Look under General Settings. What are “SIP trustrpid” and “SIP sendrpid” set to? Set trust pid to yes. send pid is either no, yes or pai. This setting is dependent on what your phone supports so try pai and yes.

I think the Yealink support PAI. I am not too familiar with Yealink so I do not know if there are config changes on the phone that need to be made to support this.

I’m sorry: in which configuration file I should check this “SIP trustrpid” and “SIP sendrpid” setting?

This is my sip.conf file content:


; These files will all be included in the [general] context
#include sip_general_additional.conf

;sip_general_custom.conf is the proper file location for placing any sip general
;options that you might need set. For example: enable and force the sip jitterbuffer.
;If these settings are desired they should be set the sip_general_custom.conf file.
; jbenable=yes
; jbforce=yes
;It is also the proper place to add the lines needed for sip nat’ing when going
;through a firewall. For nat’ing you’d need to add the following lines:
; nat=yes , externip= , localhost= , and optionally fromdomain= .
#include sip_general_custom.conf

;sip_nat.conf is here for legacy support reasons and for those that upgrade
;from previous versions. If you have this file with lines in it please make
;sure they are not duplicated in sip_general_custom.conf, if so remove them
;from sip_nat.conf as sip_general_custom.conf will have precedence.
#include sip_nat.conf

;sip_registrations_custom.conf is for any customizations you might need to do to
;the automatically generated registrations that FreePBX makes.
#include sip_registrations_custom.conf
#include sip_registrations.conf

; These files should all be expected to come after the [general] context
#include sip_custom.conf
#include sip_additional.conf

;sip_custom_post.conf If you have extra parameters that are needed for a
;extension to work to for example, those go here. So you have extension
;1000 defined in your system you start by creating a line 1000 in this
;file. Then on the next line add the extra parameter that is needed.
;When the sip.conf is loaded it will append your additions to the end of
;that extension.
#include sip_custom_post.conf

So should I add those “SIP trustrpid” and “SIP sendrpid” under [general] in sip.conf ?

I was referring to the GUI. They are set in the GUI.

I swear this setting is not available in (my) GUI, I take a look at it back and forth and cant found any :frowning:

So I edit the sip.conf manually and add those 2 line, will test it tommorow morning.

Thanks a lot, Alan!!

Do not edit sip.conf.

Besides RPID requires more than these two settings.

For RPID to work requires three things:

1 - Phones that support it
2 - Asterisk 1.8
3 - FreePBX 2.9 or later

Opss, I already edit the sip.conf manually because I cant see it anywhere in the GUI :frowning:
Cant I use FreePBX version 2.8.1 for RPID to work or I HAVE TO upgrade to the 2.9 version?

Thanks, Skyking :slight_smile:

2.8 to 2.9 upgrade is simple for FreePBX, just install the 2.9 upgrade module.

Yes, 2.9 is required to supported reverse CID. It works great.

To upgrade the freePBX can I use yum?

yum update freePBX

I read that some users get the front-end GUI damaged after update to version 2.9 because the improper upgrade

Thanks Skyking!

I don’t know anything about Elastix or their repository.

The proper way to update a FreePBX 2.9 to 2.10 is via the version upgrade module.

We do not distribute an RPM so if Elastix supports a yum upgrade you would have to discuss that with the author of the RPM.

The RPID feature works in FreePBX version 2.8.1, just tried it this morning!!

But now I have another issue: let say I pickup the call from ext A, the caller’s caller ID succesfully pass on my phone. Then I decide to pass the call to ext B (press button TRAN from the phone). On phone B, it display ext A, not the original caller’s ID. I want that on phone B it display the caller’s ID. Is there any solution for this?

Thanks you! :slight_smile:

Phone B should correctly display the caller’s ID. I typically run the FreePBX distro with Polycom handsets. On these systems the caller ID info pass correctly.

The code in FreePBX to update the caller ID wasn’t added until 2.9.

I might use a wrong procedure to transfer the call. will try again tomorrow morning.

many thanks for alan and skyking for helping me solve this problem :slight_smile:

On April 3rd, 2012 alan_mousty (tadpole) said:
Phone B should correctly display the caller’s ID. I typically run the FreePBX distro with Polycom handsets. On these systems the caller ID info pass correctly.

I’m running Elastix box using Asterisk and freePBX 2.8.1, IP Phone Yealink T20, the call transfer doesn’t pass the caller ID. I try both ways: by press “TRAN” button on the phone and by press *2. Both ways doesn’t work.

Is there anyway I can try or must upgrade the freePBX to at least version 2.9 ?

Just additional information: there is no caller id issue when using blind transfer (##NewExt)

I search and read around that this should be solved in Asterisk 1.8 ?
I am running asterisk so it should be solved now, but how?

This is a standard feature that almost every old PBX had :frowning: