ARI users cant play the voicemail recordings

I have a problem and I cant solve anyway.

I have an asterisk PBX Server working fine. No problems. The extensions declared in freePBX have enabled the recording option (always) , and the voicemails is enabled with a email account to send messages for extensions.

When a extension is not on line, logged to PBX or other reason, the message resides in /var/spool/asterisk/voicemail/default/extension number. OK perfect.

This message in voicemail extension is sending to email account and receive correctly. at that point no problems.

But if I log in ARI interface, like admin or user extension, I can’t play the messages. The web interface shows the messages in voicemail but when I do clic (and double clic also) I have this error. The emerging pop up says I need an additional plugin. I suppose the web browser is not the problem. I´m using Mozilla Firefox, but I try also with IExplorer (version 6). When I clic on download in pop up and I get this error in the pop up emerged

404 File not found!

That’s not all. Sometimes, I dont know why, I cant hear them.

The same problem succeed in Callmonitor.

I try gsm and wav format with same result. In Windows client I have installed all necessary codecs and programs (with media, shockwave, flash) for web browser

Somebody can´t tell me the reason because I cant play the message recorded in the voicemail directory with ARI Browser???
maybe permissions or owner???
How I can solve this???


Excuse for my english language. I only speak a little bit.

More info:
Software installed:
asterisk-1.2.24 asterisk-addons-1.2.7. freepbx-2.2.0-withmodules zaptel- libpri-1.2.5

/var/spool/asterisk/voicemail/default permisions

drwx-w---- 7 asterisk asterisk 4096 2007-10-19 10:54 201
drwx-w---- 8 asterisk asterisk 4096 2007-10-19 13:38 202
drwx-w---- 7 asterisk asterisk 4096 2007-10-23 15:18 203

drwx-w---- 2 asterisk asterisk 4096 2007-10-19 10:54 greet
drwx-w---- 2 asterisk asterisk 4096 2007-10-23 15:20 INBOX
drwx-w---- 2 asterisk asterisk 4096 2007-10-19 10:54 temp
drwx-w---- 2 asterisk asterisk 4096 2007-10-23 15:20 tmp
drwx-w---- 2 asterisk asterisk 4096 2007-10-19 10:54 unavail

-rw–w---- 1 asterisk asterisk 272 2007-10-22 15:29 msg0000.txt
-rwx-w---- 1 asterisk asterisk 86444 2007-10-22 15:29 msg0000.wav
-rw–w---- 1 asterisk asterisk 272 2007-10-22 15:57 msg0001.txt
-rwx-w---- 1 asterisk asterisk 161964 2007-10-22 15:57 msg0001.wav
-rw–w---- 1 asterisk asterisk 272 2007-10-22 17:46 msg0002.txt
-rwx-w---- 1 asterisk asterisk 163564 2007-10-22 17:46 msg0002.wav
-rw–w---- 1 asterisk asterisk 273 2007-10-23 15:20 msg0003.txt
-rwx-w---- 1 asterisk asterisk 151724 2007-10-23 15:20 msg0003.wav
-rw–w---- 1 asterisk asterisk 272 2007-10-23 15:20 msg0004.txt
-rwx-w---- 1 asterisk asterisk 126124 2007-10-23 15:20 msg0004.wav

We’re having a similar issue here, it appears to be totally random.

Occurs in both IE and Firefox. If you hit refresh on the popup window, it usually works fine.

Annoying bug, not sure where the problem is though.

Did a view source on a page that worked and one that didn’t and there wasn’t much change.

Checked the apache log files to no avail.

I’m getting the same issue, with both Firefox and IE. The first time you click to play the voice mail, a popup box gives an “Install Missing Plugins” message, along with “Additional plugins are required to display all the media on this page”. The second time you click on it, it works fine. After that, about 60% of the time it will work, the rest of the time it gives the “Missing Plugins” message. The .wav file that is part of the email notification works fine. On my PC, I have Media Player defaulted for these types of files, and it will play the email attachments using MP every time.
Older versions of FreePBX worked perfectly. I have one Trixbox server and one PBX in a Flash, both with FreePBX, and the problem with ARI is on both.
Anyone else having these issues?

here is how we fixed it. You will need to edit a file from the command line of the system



  $crypt = new Crypt();
  //commented out cause this doesnt work!
  //$path = $crypt->encrypt($_GET['recording'],$ARI_CRYPT_PASSWORD);
  $path = $_GET['recording'];
  if (isset($path)) {
    if (isset($_GET['date'])) {
      //echo($_GET['date'] . "<br>");
    if (isset($_GET['time'])) {
      //echo($_GET['time'] . "<br>");
    //echo $_GET['recording'];
    echo("<embed src='audio.php?recording=" . $path . "' width=300, height=20 autoplay=true loop=false></embed><br>");
    echo("<a class='popup_download' href='/recordings/misc/audio.php?recording="  . $_GET['recording'] . "'>" . _("download") . "</a><br>");


The file is /var/www/html/recordings/misc/recording_popup.php As you can see you only need to change one thing in the file

  //$path = $crypt->encrypt($_GET['recording'],$ARI_CRYPT_PASSWORD);
  $path = $_GET['recording'];

I hope this helps you out.

Thanks for the post, but for some reason, it didn’t change the outcome. Even after this update, when I click on the recording in the ARI 10 times, it will not play 3 times on the average.
The recording wouldn’t play at all when I commented this line out and added the one below:
//$path = $crypt->encrypt($_GET[‘recording’],$ARI_CRYPT_PASSWORD);
$path = $_GET[‘recording’];
Still baffled.


edited files are included there.

download and unrar the patch .

cp the 2 php files to /var/www/html/recordings/misc/

trac #2565 now has a new solution that is more secure

CRI (Crystal Clear Recording Interface) providing the user an intelligence web interface to track is recordings and his voice mail

Features :

  1. Access your voicemail recordings.
  2. Setup your voice mail box
  3. View summary of your incoming outgoing calls
  4. Search calls and recordings by day and time.
  5. Call monitor recordings.