ARI User Panel not found in FreePBX

Hello - I am trying to figure out what has happened to the ARI User Panel in our PBX installation. We’re running FreePBX (current stable), and I have FreePBX ARI Framework installed and enabled. The Module Admin page lists the version as When any of our users try to access the user panel, they are redirected to and gives a 404/Page Not Found error - which makes sense because that directory doesn’t exist.

I believe the issue began when we installed the security fix for FreePBX ARI Framework, however it is also possible that it happened a few days earlier when we ran yum update on the server in order to update bash. After doing that update, I had to issue the command “amportal chown” in order to even use the web interface, as the whole thing was screwed up and not loading. (I guess in hindsight, maybe that is more likely where everything went wrong after all?)

Anyway, when I look in /var/www/html/recordings there is only a single file, index.php, which only contains a php header redirect to the /ucp page.

How would I go about getting the ARI panel back installed for our users? I’ve reinstalled the ARI Framework from the module admin page, but it doesn’t seem to change anything. Is there some other module I need to install or reinstall? Something I need to install with yum? Something I need to manually install?

Any help is appreciated!

You somehow have a half installation of 12 going on here. Do you remember trying to upgrade to 12 at some point and then perhaps reverting?

The index.php redirect only comes from UCP, which can only be installed in FreePBX 12.

Hi Andrew - Thanks for your response.

There was no attempt to upgrade FreePBX to version 12, unless this was somehow done by yum?

As I mentioned, I ran yum update on the server on Sept 25th to get the bash update. Packages hadn’t been updated in a while prior to that, so there was actually quite a bit updated then. Here’s the log:

Updated: kernel-firmware-2.6.32-431.29.2.el6.noarch
Updated: tzdata-2014g-1.el6.noarch
Updated: bash-4.1.2-15.el6_5.1.x86_64
Updated: glibc-common-2.12-1.132.el6_5.4.x86_64
Updated: glibc-2.12-1.132.el6_5.4.x86_64
Updated: php-common-5.3.3-27.el6_5.1.x86_64
Updated: avahi-libs-0.6.25-12.el6_5.3.x86_64
Updated: php-pdo-5.3.3-27.el6_5.1.x86_64
Updated: kpartx-0.4.9-72.el6_5.4.x86_64
Updated: cpio-2.10-12.el6_5.x86_64
Updated: initscripts-9.03.40-2.el6.centos.4.x86_64
Updated: plymouth-core-libs-0.8.3-27.el6.centos.1.x86_64
Updated: ca-certificates-2014.1.98-65.0.el6_5.noarch
Updated: openssl-1.0.1e-16.el6_5.15.x86_64
Updated: asterisk-core-11.12.0-1_centos6.x86_64
Updated: asterisk-doc-11.12.0-1_centos6.x86_64
Updated: asterisk-voicemail-11.12.0-1_centos6.x86_64
Updated: asterisk-dahdi-11.12.0-1_centos6.x86_64
Updated: php-cli-5.3.3-27.el6_5.1.x86_64
Updated: plymouth-scripts-0.8.3-27.el6.centos.1.x86_64
Updated: plymouth-0.8.3-27.el6.centos.1.x86_64
Updated: php-5.3.3-27.el6_5.1.x86_64
Updated: asterisk-11.12.0-1_centos6.x86_64
Updated: asterisk-odbc-11.12.0-1_centos6.x86_64
Updated: php-mysql-5.3.3-27.el6_5.1.x86_64
Updated: avahi-0.6.25-12.el6_5.3.x86_64
Installed: kernel-2.6.32-431.29.2.el6.x86_64
Updated: kexec-tools-2.0.0-273.el6_5.1.x86_64
Updated: 1:cups-libs-1.4.2-52.el6_5.2.x86_64
Updated: php-process-5.3.3-27.el6_5.1.x86_64
Updated: sysstat-9.0.4-22.el6_5.1.x86_64
Updated: 1:grub-0.97-84.el6_5.x86_64

On Oct 1st I logged into the FreePBX web interface to attempt to update modules related to the security update notice we got. When logging in, I kept getting access denied errors accessing pages, and the CSS files wouldn’t load. We ran another yum update at that time:

Updated: php-common-5.3.3-27.el6_5.2.x86_64
Updated: nss-util-3.16.1-2.el6_5.x86_64
Updated: bash-4.1.2-15.el6_5.2.x86_64
Updated: nss-softokn-freebl-3.14.3-12.el6_5.x86_64
Updated: nss-softokn-3.14.3-12.el6_5.x86_64
Updated: nss-sysinit-3.16.1-7.el6_5.x86_64
Updated: nss-3.16.1-7.el6_5.x86_64
Updated: php-pdo-5.3.3-27.el6_5.2.x86_64
Updated: php-cli-5.3.3-27.el6_5.2.x86_64
Updated: php-5.3.3-27.el6_5.2.x86_64
Updated: php-mysql-5.3.3-27.el6_5.2.x86_64
Updated: nss-tools-3.16.1-7.el6_5.x86_64
Updated: php-gd-5.3.3-27.el6_5.2.x86_64
Updated: php-process-5.3.3-27.el6_5.2.x86_64

This didn’t resolve the issues, so after a bit more digging online, I found the “amportal chown” command, ran it, and the web interface started working normally again. I was able to install the security fix.

No other changes were made between then and when I was notified that the voicemail web interface was broken.

Would any of those updates downloaded by yum have partially updated FreePBX?

Regardless, I’d really appreciate some help getting the control panel back. Is there some other module I need to install or reinstall?

rm -Rf /var/www/html/recordings/*
amportal a ma delete fw_ari
amportal a ma download fw_ari
amportal a ma install fw_ari

Thank you very much! I ran the commands and everything is working again.