ARI setup

I do of course want to use the ARI interface withing FreePBX…

It doesn’t play for me…

I can log in using my extension as username and the provided password… Works just fine, but NO recordings at all show up. I first thought that maybe ARI checkes for the recordings using an incorrect path. Seemed to be the obvious reason…

I’ve checked the conf file for ARI in …//amp/recordings/includes/main.conf.php it says, among other things, …
$ASTERISK_VOICEMAIL_PATH = “/var/spool/asterisk/voicemail”;

I go to that folder and do this
cryptonite voicemail # ls
default device
cryptonite voicemail # pwd
/var/spool/asterisk/voicemail
cryptonite voicemail # cd default/2000/INBOX/
cryptonite INBOX # ls
msg0000.WAV msg0000.txt msg0001.WAV msg0001.txt msg0002.WAV msg0002.txt msg0003.WAV msg0003.txt msg0004.WAV msg0004.txt msg0005.WAV msg0005.txt
msg0000.gsm msg0000.wav msg0001.gsm msg0001.wav msg0002.gsm msg0002.wav msg0003.gsm msg0003.wav msg0004.gsm msg0004.wav msg0005.gsm msg0005.wav

There seem to be plenty of voicemails laying around and the autmatic mailing feature works. I get the voicemails in my inbox correctly so I assume that everything should be setup correctly…

But still, no recordings show up in ARI…

PS. It tried to change $ASTERISK_VOICEMAIL_PATH to
"/var/spool/asterisk/voicemail/default". That didn’t help at all ;o)

Does anyone here have a clue?

Thanks a lot!!

/Peter

ls -al

Sooo obvious… I don’t know what I was thinking of…

Thank you… the files are created as user ‘asterisk’ and httpd is run as ‘apache’…

Thanks!

You should run httpd as asterisk if you have not done it already…

I am getting the same issue, but my permissions seem to be correct. Here is what I am getting in my httpd error log:

[code:1]
[client xx.xx.xx.xx] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/recordings/modules/voicemail.module on line 788, referer: http://xx.xx.xx.xx/recordings/index.php?m=Voicemail&f=display
[/code:1]

Fixed it. As Bubba said. It was a permissions problem. My files were set for asterisk perms, but asterisk was running as root. To fix, I just typed in AMPORTAL RESTART, and AMPORTAL CHOWN. This fixed my issue.