ARI broken

new install of PIAB – everything is up and going and then ARI goes wonky

the error:

ARI does not appear to have access to the Asterisk Manager. ()
Check the ARI ‘main.conf.php’ configuration file to set the Asterisk Manager Account.
Check /etc/asterisk/manager.conf for a proper Asterisk Manager Account
make sure [general] enabled = yes and a ‘permit=’ line for localhost or the webserver.


here the manager file

; Asterisk Call Management support
enabled = yes
port = 5038
bindaddr =

secret = amp111
read = system,call,log,verbose,command,agent,user
write = system,call,log,verbose,command,agent,user

#include manager_additional.conf
#include manager_custom.conf

take a look in the pbx-in-a-flash forums at

i had the same issue and posted the fix along with a few easier ways to fix than the way i did it

Yep, tbooth fixed it or did he??

Just FYI here…when you take the time to post a note on how you FIXED it, then take another 2 seconds and post the fucking link to the page where the fix is located…great job moron

this is for tbooth, tbooth’s moto

here is his lame FIX, which by the way could have been summed up in half the words he used in his post…but anyway, here it is

one of the most frustrating posts i’d seen. i appreciate the help.