Are there any special settings for wireless telephony (DECT)


(Just Another User) #1

Hi guys,

I have built a FreePBX system.
Everything goes wonderfully without any problems, the desktop phones
(Yealink) are working fine.

But I also have a multi-cell DECT system from Gigabit (N720 DM) with a manager and some base stations for seamless handover/roaming of the devices.

There are indeed some inconsistent problems here.

Sometimes the DECT devices cannot call or are not reachable.
Often the devices continue to ring even though they have been answered or rejected.
Rarely you don’t hear any speech or the call starts very delayed.

But as soon as you get a call through, the voice quality is normal.

Does it sound more like a problem with SIP signaling than a problem with RTP transmission?
The problems all occur with internal telephony.

The only difference between the settings in the extensions is that ‚Media Encryption Optimistic’ is enabled, because the Gigaset devices cannot use SRTP (with media encryption enabled).

So are there any settings you need/should set for wireless telephony (especially DECT)?
Or does anybody have an idea what could cause these problems?

Many greetings and many thanks.


(Just Another User) #2

No special tips or best practices for wireless (DECT) extensions?

I have read a little bit in the forum and in case of problems with DECT they mentioned here in some topics to disable ‘Symmetric RTP’ and generally use ‘Chan_SIP’ instead of ‘PJSIP’ for DECT.

I will try both and give feedback.

If anyone has any advice or further ideas I would be very grateful.

Many greetings


(Just Another User) #3

Hi guys,

After some tests it turned out that the SIP_Chan drivers are much better suited for our DECT telephony (at least for the model ‘Gigaset N720 DM PRO’).
The setup of the calls is much more reliable.

In addition there was a problem with dropped packets (broken audio streams from time to time), which was caused from the calling DECT devices.
After some error analysis, the network-bounding cards are to blame for this problem.

If the FreePBX is operated in a virtual machine on the Hyper-V and several network interfaces are connected together (called Team-NIC by Microsoft), then these call interruptions occur.

Frequently there is the problem with the Team-NIC that the MAC addresses are used twice. This problem can be solved by assigning individual MAC addresses.
( see: https://robertsmit.wordpress.com/2014/03/10/a-port-on-the-virtual-switch-has-the-same-mac-as-one-of-the-underlying-team-members-on-team-nic-event-id-16945-winserv/ )

But this does not solve the problem with the Gigaset. Here is a forum post in which the problem is mentioned again.
( Gigaset N720 and FreePBX losing a few seconds of DECT handset audio )

Kind of the same problem.
You can of course dissolve the Team-NIC or switch one of the adapters to standby (if you only have 2 adapters in the Team-NIC), but this is no solution for us.
We installed an additional network card and could switch the VM (FreePBX) to this single network card (without Team-NIC).

This solves the problem. Other models (also DECT) for example Yealink do not have this problem at all and have no problem with a Team-NIC.

We have informed the Gigaset support, but have not yet received any feedback.

If I still get any information I will share it here.

Many greetings.