FreePBX | Register | Issues | Wiki | Portal | Support

Apply Config does not work


(Admin122) #1

I updated my distro last night and the apply config button in the web GUI has stopped working. I upgraded from FreePBX 13.0.195.12 to the newest release. Everything appears to work fine but when I try to make configuration changes via the web GUI I get this error.

exit: 1 Unable to continue. Illegal string offset ‘target’ in /var/www/html/admin/modules/customappsreg/functions.inc.php on line 59 #0 /var/www/html/admin/modules/customappsreg/functions.inc.php(59): Whoops\Run->handleError(2, ‘Illegal string …’, ‘/var/www/html/a…’, 59, Array) #1 /var/www/html/admin/libraries/usage_registry.functions.php(300): customappsreg_getdestinfo(‘ivr-1,s,1’) #2 /var/www/html/admin/libraries/usage_registry.functions.php(351): framework_identify_destinations(Array, Array) #3 /var/lib/asterisk/bin/retrieve_conf(818): framework_list_problem_destinations(Array, false) #4 {main}

How do I start to trouble shoot this?


(Itzik) #2

What is this module?


(Lorne Gaetz) #3

What is the output of the following:

fwconsole m
select * from custom_extensions;

(Admin122) #4

Thanks for your replay. I will let you know tomorrow. I had to restore from a snapshot so our phones would work today.


(Admin122) #5

empty data set


(Lorne Gaetz) #6

No idea what’s going on, but if you run into it again you can prob fix by getting rid of the module:

fwconsole ma delete customappsreg

(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.