Anyone get an Avaya 9611 phone working with Asterisk?


#1

I’ve acquired an Avaya 9611g IP phone and would like to know if there’s any documentation on having this work with Asterisk/ FreePBX?

I need to 1) update the firmware on the phone for the latest SIP firmware (which I’m researching how to do) and 2) somehow configure basic SIP functionality for the phone using my FreePBX instance.

Any advice or help with #1 or #2?


#2

Ok I’ve made much progress. I’ve been able to update the phone’s firmware and create the phone’s configuration file.

The current problem is that I cannot get the phone to log in correct. After entering the username (extension) and password (voicemail password I assume, not the secret), the phone is stuck on “Acquiring Service…”. I read in a tranlated russian blog that the problem was within sip.conf, but they didn’t describe what.

I’ve tried to connect via UDP and TCP, changing the extension settings within FreePBX each time.

Any advice? I think this is an Avaya IP phone thing in general, not specific to the 9611g model.


(Dave Burgess) #3

The phone needs to connect (the first time) using the secret. These entries should match the entries in your sip config for that extension.


(Rogue Focus) #4

did you ever get this working? I’m stuck aquiring services too…


#5

Nope, I did not ever get this working.


(Rowan Salabie) #6

Disable NAT in FreePBX to make it work. If you’re still having issues, I can post my config file. So far, I’ve gotten the 9620, 9630, 9608G and 9611G to work with Asterisk.


(Rogue Focus) #7

tried with nat=no. no luck. can someone please share a 46xxsettings.txt that works?

thanks


MWI and VOIP Provider
(Rowan Salabie) #8

Not everything here is necessary to make it work. Probably only the SIP_CONTROLLER_LIST:

DNSSRVR 8.8.8.8
SET DOMAIN 192.168.1.100
SET SIPDOMAIN 192.168.1.100
SET SIPPORT 5060
SET SIP_CONTROLLER_LIST 192.168.1.100:5060;transport=tcp
SET SIPREGPROXYPOLICY alternate
SET CONFIG_SERVER_SECURE_MODE 0
SET SIPPROXYSRVR 192.168.1.100
SET SIPSIGNAL 1
SET SIP_PORT_SECURE 5061
SET ENABLE_AVAYA_ENVIRONMENT 0
SET DIALPLAN [2-8]xxx|91xxxxxxxxxx|9[2-9]xxxxxxxxx
SET PHNNUMOFSA 4
SET SNTPSRVR 192.168.1.100
SET GMTOFFSET -5:00
SET DSTOFFSET 1
SET DSTSTART 2SunMar2L
SET DSTSTOP 1SunNov2L
SET DISPLAY_NAME_NUMBER 1
SET SIG 2
SET HTTPSRVR 192.168.1.100
SET MSGNUM *97
SET ENABLE_EARLY_MEDIA 1
SET RTP_PORT_LOW 10001
SET RTP_PORT_RANGE 9999
SET SIG_PORT_LOW 5060
SET SIG_PORT_RANGE 1

Also, add “tcpenable=yes” to your Other SIP Settings configuration.


#9

try setting up your dhcp server to point to your iis server that houses your 46xxsettings.txt file and also your firmware files. You can chose between sip or h323. In this case you probably want the 6.7 sip firmware.


(David Mc Clellan) #10

Thanks for the info.
I am connected to Freepbx with Avaya 9620 and 9630 but the issue I am having is when I make a call from the Avaya phone internal “voicemail” or another phone on Freepbx “Grandstream” or outside every other call works. The first call goes through and the second call gets a busy signal. I don’t believe it is in the Freepbx settings because I swamp extensions and the issue stays with the Avaya phone. I have tried multiple settings the Avaya but still a no go.
Thanks.


#11

I did at one point but I could never get the message lamp or the BLF’s to work correctly.


#12

Hello, trying to connect an Avaya 9621G to Freepbx.
UPDATE : Successful ! See the end of this post.

What I found is : Connecting in UDP does not seem to work well. When I try to connect (set username and password), the phone displays “Acquiring service…” forever.
The Avaya phone speaks on port 1025, and Asterisk tries to connect to 5060, although I have port=1025 in the phone config. I see lot of 0.0.0.0 adresses in the log. Here is SIP debug log (192.168.1.93 is the address of the phone) :

<--- SIP read from UDP:192.168.1.93:1025 --->
REGISTER sip:192.168.1.182 SIP/2.0
From: <sip:49@192.168.1.182>;tag=386ddfa8-32f830d71d5y635t5991d185n3gt3b392s3e6f5n2r_F490.0.0.0
To: <sip:49@192.168.1.182>
Call-ID: 15_386ddfa86c8d1c495hw37314h321s5b5a3p456i3m6f4t2e2e3c_R490.0.0.0
CSeq: 21 REGISTER
Max-Forwards: 70
Via: SIP/2.0/UDP 0.0.0.0;branch=z9hG4bK15_386ddfa81b77ea011s4ai4k4v2j5x1v5d3i243x4i1p10165g2w_R490.0.0.0
Supported: eventlist,feature-ref,replaces,tdialog
Allow: INVITE,ACK,BYE,CANCEL,SUBSCRIBE,NOTIFY,MESSAGE,REFER,INFO,PUBLISH,UPDATE
User-Agent: Avaya one-X Deskphone 7.0.0.39 (39)
Contact: <sip:49@0.0.0.0;transport=udp;avaya-sc-enabled>;q=1;expires=900;avaya-actions="presence.initiate-pubsub,presence.redirect";+avaya.gmtoffset="0:00";+avaya.js-ver="1.0";+avaya.model="9621";+avaya.sn="11WZ471604VR";+avaya.firmware="S96x1_SALBR7_0_0r39_V4r83.tar";+sip.instance="<urn:uuid:00000000-0000-1000-8000-2cf4c5eea0b0>";reg-id=1
Content-Length: 0

<------------->
--- (12 headers 0 lines) ---
Sending to 192.168.1.93:5060 (no NAT)

<--- Transmitting (no NAT) to 192.168.1.93:5060 --->
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 0.0.0.0;branch=z9hG4bK15_386ddfa81b77ea011s4ai4k4v2j5x1v5d3i243x4i1p10165g2w_R490.0.0.0;received=192.168.1.93
From: <sip:49@192.168.1.182>;tag=386ddfa8-32f830d71d5y635t5991d185n3gt3b392s3e6f5n2r_F490.0.0.0
To: <sip:49@192.168.1.182>;tag=as19942915
Call-ID: 15_386ddfa86c8d1c495hw37314h321s5b5a3p456i3m6f4t2e2e3c_R490.0.0.0
CSeq: 21 REGISTER
Server: FPBX-2.8.1(1.8.20.1)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="7f016178"
Content-Length: 0

So it is better to connect in TCP. I set it in the CRAFT procedure of the phone, in SIP menu and SIP Proxy Server configuration.

I added in Asterisk SIP settings :
tcpenable=yes
tcpbindaddr=0.0.0.0

I also set nat=no, as recommended in this post.

Now the situation is :

Communication seems OK in the log. The port is the same for sending and receiving, and I no longer see 0.0.0.0 addresses. On the phone, the message sent appears on the screen.

If I deliberately set a wrong password, I get : 403 Forbidden (Bad Auth)
If I set the right password, I get : 403 Forbidden.

And no reason is indicated for the error.

I am stuck there and don’t know what may be wrong.

=========================================================

UPDATE : I found the problem.

The log indicated that this extension was not set for TCP.

I added transport=tcp in the extension configuration (sip_additional.conf) and now the phone works in FreeBBX !
I am using Elastix 2.5

I will post later a more detailed report of all the steps necessary to have this beautiful phone work with FreePBX / Elastix


(Thomas Kardos) #14

Thanks for the help, i managed to log in with an Avaya 9608, but i am unable to call conference numbers or to hang up calls by pressing the headset/speaker button, the phone says “limited phone service” have you ever gotten further?


(Duqad) #15

May I ask the location of this file? Is it on the FreePBx server or on the phone?

I am new to freePBX please excuse my ignorance about This topic.

Thx


#16

Hi,
I am aware that by setting password to NULL (empty password field of extension) will cure “every other call busy signal” issue.

I’ve seen the issue was cured by rolling back to 2.5 firmware instead of 2.6 (in my environment SIP96xx_2_6_12_1.bin is installed on both 9620 and 9630/9630G), I want to try whether it is true but I can’t download old firmware anymore from Avaya site…


(Communication Technologies) #18

Did you ever figure out how to get the exclamation point in the top left of the screen to clear?


(Communication Technologies) #19

Did you ever figure out how to add feature codes, like call parking, via the 46xxsettings file?