Any way to avoid devices and users mode for this config? PJSIP?

TL;DR: If in extensions mode, and an extension (A) with follow-me enabled points to another extension (B) with follow-me enabled, calls don’t flow through to the extensions defined in B’s follow me list.

A few months ago I upgraded our office from a very old AsteriskNow install. We are using FreePBX distro 13 since it seemed better supported than AsteriskNow. One piece of functionality we relied on was the ability to have a single extension ring multiple phones. When we upgraded, I tried to avoid “users and devices” mode, but was unable to get the desired functionality with extensions.

We have some remote users that only use a cell phone, and a few local that want the ability to have both their desk phone and cell phone ring. We have SIP desk phones configured with PJSIP, and I’ve added the cell phones as custom devices using a dial string like “local/[email protected]

If I set the user to the desired extension on both devices, both phones will ring. So far this would have worked with extensions mode using follow me.

The problem comes from the shared extensions we use. We have a few shared extensions for things like “support” or “orders.” If we add an extension that has follow-me enabled, it will ring the SIP phone, but will not carry over to the cell phone assigned as a custom extension. Also transferring a call to that extension will only ring the desk phone, not the custom extension set up as a follow me.

Is there a way to use extensions mode instead of users & devices mode and get the transfers and follow me to carry through to the cell phone listed under follow me for the extension? Is this by design or was it perhaps a bug?

Edit: Solved - need to add a “#” at the end of an extension listed in a Follow Me for the calls to flow through to another Follow Me.

Use a ring group with the extension that you want to ring and the mobile phone number with a # at the end.

I’m pretty sure we tried that (as well as adding the cell numbers directly to the follow me), but the cell phones still didn’t ring when you transferred a call to the follow me or ring group.

I’m a little unclear on several things:

  1. Does your custom extension ever work? What happens when you dial it directly?

  2. Since it’s a “local extension”, you certainly don’t need the '#" at the end of the number, but why are you using a custom extension? What is preventing you from using the phone number of the cell phone with a :"#" at the end?

  3. What do your logs say when you try this? I’m willing to bet that the answer to your question is clearly laid out there.

  1. The custom extension works when dialed directly.
  2. I have tried with both the custom extension, or manually adding the number with a “#” at the end, I get the same results.

I just set up a VM using a google voice trunk with extension mode to test this out again. To better clarify on this, I’ve created a very specific example.

  • incoming caller id is 5551111111
  • my external cell is 5552222222
  • not using the custom extension for the time being to simplify things
  • my extension is 369. I have added my cell phone to the “Follow-Me List” for 369 as “5552222222#”
    • I left 369 in there as well
  • An outside caller calls and dials extension 369, both my desk phone and cell phone ring.
  • extension 343 is our tech support extension.
  • the “Follow-Me List” for 343 has 369
  • An outside caller calls and dials extension 343 only the desk phone rings. The call doesn’t go out to the cell phone.
  1. I grabbed logs with “asterisk -vvvr.” Please let me know if I should do this a different way.

I have the full logs saved locally for the two examples above, but need to scrub them.

When 369 is dialed directly I get:

dialparties.agi: Starting New Dialparties.agi
dialparties.agi: Caller ID name is ‘5551111111’ number is '5551111111’
dialparties.agi: Methodology of ring is ‘ringall’
– dialparties.agi: Added extension 369 to extension map
– dialparties.agi: Added extension 5552222222# to extension map
– dialparties.agi: Extension 369 cf is disabled
– dialparties.agi: Extension 5552222222# cf is disabled
– dialparties.agi: Extension 369 do not disturb is disabled
== dialparties.agi: Discovered PJSIP Endpoint PJSIP/369
– dialparties.agi: Ended up with real PJSIP Dial string PJSIP/369/sip:[email protected]:5060
– dialparties.agi: dbset CALLTRACE/369 to 5551111111
– dialparties.agi: Filtered ARG3: 369-5552222222
– <Motif/+15551111111-ff66>AGI Script dialparties.agi completed, returning 0

When the outside line instead calls the support extension 343:

dialparties.agi: Starting New Dialparties.agi
dialparties.agi: Caller ID name is ‘Sup: 5551111111’ number is '5551111111’
dialparties.agi: Methodology of ring is ‘ringall’
– dialparties.agi: Added extension 369 to extension map
– dialparties.agi: Extension 369 cf is disabled
– dialparties.agi: Extension 369 do not disturb is disabled
– dialparties.agi: dbset CALLTRACE/369 to 5551111111
– dialparties.agi: Filtered ARG3: 369
– <Motif/+15551111111-895d>AGI Script dialparties.agi completed, returning 0

My cell number (5552222222) doesn’t show up anywhere in the logs when the caller dials 343.

Please let me know if anything isn’t clear or if more of the logs would be useful.

It sounds like it should work - FMFM isn’t normal dialing, but it still react “pretty close” to what happens when you local dial.

In the FMFM tab for your number, try adding “5552222222#” instead of 369. It should (I think) try to call your cell phone.

Another thing you can try is to create a ring-group with the 369 extension. Add your 343 extension and 5552222222# to that and see what happens.

I tried with a ring group and had the same result. So FMFM -> FMFM does not call the external, and Ring Group -> FMFM does not call the external. I also tried with an internal extension instead of an external number.

So a FMFM -> FMFM does not go through. I guess I’ll file a bug, that way at least I can find out if it is desired behavior or a bug.

Edit: filed an issue http://issues.freepbx.org/browse/FREEPBX-12473

Answer is to put a “#” at the end of the extension in the first FMFM.

So in my example put 369# in the FMFM for 343, and it will cause numbers in the 369 FMFM to ring.