Any DID route blocking all calls


Brand new system loaded with the FreePBX Distro Stable-5.211.65 32 bit (Asterisk 11.13.1/FreePBX We have seven DID numbers which I’ve created inbound routes for and everything is working.

When I create a generic Inbound route (DID & CallerID are both blank), all inbound calls fail and default to a message saying the number is disconnected.

I can see the calls hitting the server, but they are not being routed properly. Once I delete the generic inbound route, all my other routes start working again.

The CDR report shows a blank incoming DID in the general report, but if I click into the detailed report, the DID number shows correctly.

I probably don’t need the generic inbound route, but I do like having it just in case a call comes in and the DID got scrambled.


It might be helpful to have a call trace of the failed call.

Turns out it wasn’t a FreePBX issue. Voice provider is using two different IP’s for inbound calls. Had to set up a second trunk to recognize the second IP for inbound calls (I left all of the Outgoing trunk info blank, except for trunk name which is required, and only filled out the minimal info needed for Incoming trunk)…

Now all seems to working as it should.


Can you please share? I am having the exact same issue.


I created extra trunks. Leave the fields for the Outgoing Settings empty, except for the trunk name, which needs to be filled out.

For the Incoming Settings, fill out the USER context (usually “from-trunk”) and USER details.

USER details should only need the following info:
host=hostname or IP address


Thanks for the reply…

I have set up additional trunk with Usercontext as below


But for incoming call, it is still rejecting the call with unauthorized

<— SIP read from UDP: —>
ACK sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK0d72.2d4cf737.0
From: “6590705449” sip:[email protected];tag=as5f2f7f4a
Call-ID: [email protected]:5060
To: “6567146604” sip:[email protected];tag=as339a2d78
CSeq: 102 ACK
Max-Forwards: 70
User-Agent: OpenSIPS (1.7.2-tls (x86_64/linux))
Content-Length: 0