Anveo Direct Setup


#1

Hi can anyone here help with getting Anveo Direct setup on the FreePBX?


(Adam Kayden) #2

here you go. add pjsip trunk


#3

Hey thanks @AdamKayden . I don’t see the registries connected to the trunk.



Peers:
Endpoint: AnveoDirect Unavailable 0 of inf
Aor: AnveoDirect 0
Contact: AnveoDirect/sip:sbc.anveo.com:5060 hash NonQual nan
Transport: 0.0.0.0-udp udp 3 96 0.0.0.0:5160
Identify: AnveoDirect/AnveoDirect
Match: 50.22.101.14/32

Nothing in the Advanced section of the PJSIP?

In my Anveo settings : Destination SIP Trunk =
Primary SIP URI - $[E164]$@000.000.000.000:5060

obviously with my server IP instead of 000.000.000.000

Outbound service = really basic
No dialing prefix
Added my authorized ip
everything else default.

Any ideas?


#4

This trunk does not register, so this is correct. This trunk is defined simply by the hostname sbc.anveo.com.


#5

Oh, so it should just work? Is there somewhere I should look to see if it is connected properly or just test everytime I wan’t a health check?


#6

Inbound and outbound don’t work.


#7

Debugging SIP trunks… if you are in the terminal, asterisk -r to get in the Asterisk CLI and then pjsip set logger on to get the SIP output printed to the screen. Also core set verbose 9 will get you more output from the dialplan.

What happens when you send a call to the trunk? Can you verify FreePBX is selecting the Anveo trunk (based on your Outbound Routes)? Is it sending the call in the format Anveo wants? etc. These are the troubleshooting steps I’d go with. Sorry if you already know it; I’m not trying to be condescending.

Also, from the Anveo Direct FAQ:

What IP addresses should I open on my firewall?

You need to allow the following IP addresses to reach your network: 67.212.84.21 - SIP Signaling
176.9.39.206 - SIP Signaling
50.22.102.242 - SIP Signaling
50.22.101.14 - SIP Signaling
72.9.149.25 - SIP Signaling

You should put each of these IP addresses in the Match field of your PJSIP trunk to ensure you receive incoming calls from Anveo.


#8

Hey @billsimon , great suggestions as always. I got the outbound to work (was very stupid – phone wasn’t allowed to use the new trunk). I still can’t get the inbound to work and I don’t even see it coming into the freepbx.

The Destination SIP Trunk on Anveo is very straight forward. I gave it a random name and then for the Primary, it is set to SIP URI:
$[E164]$@xxx.xxx.xxx.xxx:5060

Not sure why it isn’t working.


#9

So when I setup my FreePBX, in my asterisk SIP settings, I changed PJSIP to listen to 5160 and Chan_sip to listen to 5060. I haven’t had any issues connecting to any other trunks, so I presume this isn’t the issue? Should I be changing the SIP URI to :
$[E164]$@xxx.xxx.xxx.xxx:5160

??


#10

Yes, that’s it. If you set up a PJSIP trunk and PJSIP is listening on 5160, you need to put that in your Anveo SIP URI.


#11

ok. I have other PJSIP trunks setup to other providers that show as connected to 5060 though. Is that odd?


#12

You are talking to them on port 5060 and they are talking to you on port 5160. This is all perfectly fine.

How do they know to talk to you on 5160? if you are using registration, which I guess you are for your other trunks, then Asterisk tells them you are listening on 5160 as part of the registration message.


#13

Oh I see… ok thanks a ton Bill. As always, you are a wealth of information!


#14

One last thing - if you don’t need chan_sip, disable it. It is not needed unless you specifically want to use it.


#15

Where would I disable it?


#16

Settings —> Advanced Settings —> SIP Channel Driver: choose pjsip only.


#17

Thanks again Bill