Another fwconsole not accessible

Hello all, seems I’ve come upon a semi-common problem but I’m not sure how to proceed from the previous posts I’ve read. I’m getting this lovely message when I login via SSH:

** CRITICAL SYSTEM ERROR **

Unable to generate MOTD.
The /usr/sbin/fwconsole file is not accessible

You are likely to experience significant system issues.


 _____              ____  ______  __
|  ___| __ ___  ___|  _ \| __ ) \/ /
| |_ | '__/ _ \/ _ \ |_) |  _ \  / 
|  _|| | |  __/  __/  __/| |_) /  \ 
|_|  |_|  \___|\___|_|   |____/_/\_\

Yay! So off to the races:

[[email protected] ~]# locate fwconsole
/usr/local/sbin/fwconsole
/usr/src/freepbx-13.0.64/amp_conf/bin/fwconsole
/usr/src/freepbx-13.0.64/amp_conf/htdocs/admin/modules/framework/amp_conf/bin/fwconsole
/var/lib/asterisk/bin/fwconsole
[[email protected] ~]# 

Well then, I never!

[[email protected] ~]# asterisk -x "core show version"
Asterisk 13.13.1 built by mockbuild @ jenkins2.schmoozecom.net on a x86_64 running Linux on 2016-12-16 04:48:00 UTC
[[email protected] ~]# 
[[email protected] ~]# /var/lib/asterisk/bin/freepbx_engine

/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_dahdiconfig: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_endpoint: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_pagingpro: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_restapps: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_ucp: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_ucpnode: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_vqplus: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_xmpp: No such file or directory
!!!!amportal is depreciated. Please use fwconsole!!!!
forwarding all commands to 'fwconsole'
 ______             _____  ______   __
|  ____|           |  __ \|  _ \ \ / /
| |__ _ __ ___  ___| |__) | |_) \ V /
|  __| '__/ _ \/ _ \  ___/|  _ < > <
| |  | | |  __/  __/ |    | |_) / . \
|_|  |_|  \___|\___|_|    |____/_/ \_\
FW Console - FreePBX Utility version 13.0.190.11
...
output omitted (command help)
...
[[email protected] ~]#

Maybe this will help you help me :wink:

[[email protected] ~]# ll /usr/src/
total 76
-rw-r--r--  1 root root  5496 Aug  6  2015 bash-common-functions.sh
drwxr-xr-x  8 root root  4096 Aug  6  2015 cdr-stats
-rw-r--r--  1 root root 31085 Aug  6  2015 cdr-stats-functions.sh
drwxr-xr-x. 9 root root  4096 Jan 23 00:36 debug
lrwxrwxrwx. 1 root root    24 Feb  9  2015 freepbx -> /usr/src/freepbx-12.0.21
drwxr-xr-x. 3 root root  4096 Jun 27  2015 freepbx-12.0.21
drwxr-xr-x  2 root root  4096 Feb 17  2016 freepbx-12.0.45
drwxr-xr-x  6 root root  4096 Feb 17  2016 freepbx-13.0.64
-rw-r--r--  1 root root  1724 Aug  6  2015 install-cdr-stats-asterisk.sh
-rw-r--r--  1 root root  3588 Aug  6  2015 install-cdr-stats.sh
-rw-r--r--  1 root root  2742 Aug  6  2015 install-mongodb.sh
drwxr-xr-x. 4 root root  4096 Feb 17  2016 kernels
[[email protected] ~]# 

This says:

[[email protected] ~]# cat /etc/schmooze/pbx-version
6.12.65-32
[[email protected] ~]# 

But the GUI says:

and elsewhere:

Full disclosure, I don’t fully grasp the FreePBX/Asterisk version numbering. I pretty recently performed the sysadmin pro 12-13 upgrade hoping that would resolve the error message but it did not. (It did however give me the nice new GUI.) I expected that to switch me to Asterisk 13 but it didn’t so I did ‘asterisk-version-switch’ from the CLI and that seemed to work and the pjsip driver is now available for use.

I suspect this is all due to some sort of failed upgrade. I inherited the system and the previous administrator had no documentation or even notes to give me.

This system is fully licensed with just about every commercial module available. We are a FreePBX reseller and while we’re troubleshooting this on our internal system, we have customer facing systems that appear to be in the same boat.

Failing a better suggestion I’m going to put on my cowboy hat, wait until folks go to bed, take a snapshot and run https://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-1.sh and hope for the best.

Thanks ahead for any input!

Are you sure you are logging as root ?

lol yes I’m sure. Also, an update, that script fixed my little red wagon. I’m all set, thanks!

https://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-1.sh