Another FOP2 question

Hello all,
Well I have finally taken the plunge and delved into the new stable 2.210.62-3 and firstly I must say I am impressed.
There is a much more logical layout to the Settings Menu as well as inclusion of the basics that was missed in some of the Betas.
The boot time is incredible and it seems very stable.
First install to fully operational took me around an hour.

Only question I have (so far) is FOP2.
I read an earlier post saying that the x86 version for Centos 6 was available by yum install fop2-fpbx.
I have done this and all seems to have installed fine.
Problem is when I try to use it, I get the login page and after putting in credentials I get the same login page again.

When I run
service fop2 restart
I get
grep: /var/www/html/panel/op_server.cfg: No such file or directory
Although it says it starts fine.

I have added the symlink
ln -s /usr/lib/libcrypto.so.10 /usr/lib/libcrypto.so.6
from
http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/unable-to-install-fop2-on-distro-1-817-62
but still no good.
I have tried this with IE, Firefox and Chrome all to no avail (obviously as the file is missing)
Can anyone help please?

Cheers in advance.

I had a similar problem with my 64-bit install and Nicolas was kind enough to provide a beta of 2.27 which worked perfectly. I’ve requested a 32-bit version for another CentOS 6.2 install that I got going a few weeks ago, but have yet to hear back. Here’s the thread: http://www.fop2.com/forum/viewtopic.php?f=4&t=1568 (with a download link!)

Thanks for the reply. I read your post earlier while looking into this.
Will wait on 32 bit version as well.
Can you let me know when it is out?
I prefer to use the one from the freepbx repo but if not working will try direct install.

Honestly, I’d suggest that you post a request on that thread as well - Nicolas isn’t always the fastest in responding to posts, but maybe if he sees there’s some demand he’ll get moving :slight_smile:

Have posted the below in FOP2 forum but maybe as i got FOP2 from the FreePBX repos i thought i should put in here as well.

I tried again on a fresh install of FreePBX Distro 2.210.62-5 and I get the same thing.
I have setup 3 extensions, all with voicemail access numbering 2000,2001,2002 and passwords 123789 (not real extensions or passwords listed) and each time i try to login to fop2 i get the login box come back.
Interstingly when using the chrome extension i currently have scrolling around the icon Invalid Credentials.
I have double checked and triple checked … even made then 1234 for each and all to no avail.
When i put into the CLI service fop2 restart, i get the below come up.

[[email protected] ~]# service fop2 restart Shutting down Flash Operator Panel 2: [ OK ] grep: /var/www/html/panel/op_server.cfg: No such file or directory Starting Flash Operator Panel 2: [ OK ] [[email protected] ~]#
I downloaded FOP2 through the FreePBX repos via yum install fop2-fpbx

Any Help would be much appreciated.
Pezzz

So it seems things have changed since i last setup FOP2.
By default users are not included when you give them a voicemail setup.
You need to go into the FOP2 Users button and allow the user with the permission and set password.
Thanks for the help on here and in the FOP2 forum.