Anonymous calls with call prefix on Cisco phones


CID prefix for a incoming call on a cisco sip phone does not work because the phone rewrites every anonymous call to “anonymous caller” (or any other language) in the display.

Is there a way to modify freepbx or asterisk that anonymous calls are presented as “unknown” to get the CID prefixes working with cisco phones? Phones from every other brand shows the cid prefix correct, this is not a setting problem.

I’ve searched the internet and many people have this problem but never found a solution. See

Not sure if you fixed this problem but I would like to share the fix.
I too had the same problem and could not find a fix anywhere, it took me sometime and playing around but I found the fix. The problem is the default setting on the Cisco phone. I have the SPA504G I’m sure this will work on all SPA.

Login to the Cisco phones Configuration Utility as admin and Advanced. Go to the “SIP” tab and look for “Display Anonymous From Header:” it will be set as “NO”, change it to “Yes” and submit changes.

Now anonymous calls should display the queues prefix.