Anonymous caller ID for internal extensions Cisco 79XX

Hi everyone.
I’ve setup two Cisco 79XX phones with an internal extension of 400 and 500 using Chan_sip. They work fine but when calling between them the caller id comes up anonymous. Any ideas why its not using the CID 400 and 500 I’ve set in the extension of each ?

I have two other extensions setup as PJ_SIP and they work fine and show their caller ID even when calling the Cisco phones.

Regards,

You should move to chan_pjsip then. Chan_sip is basically dead. It gets removed next year.

I don’t think the Cisco phones can be configured with chan_pjsip as they need pure TCP not UDP. Or am I mistaken?
Regards,

PJSIP supports UDP, TCP, and TLS.

1 Like

You are gravely mistaken. Nothing has ever stated they need TCP exclusively. Not to mention these are EOL phones that no one has touched or updated in years.

Is there anything special needed to configure in the PJSIP settings or in the advanced tab for the extension. I’ve changed the .xml file on the Cisco to reflect the new port 5060 and activated tcp - 0.0.0.0 - All but it won’t register.

Do you see the register attempt on the server? You can run sngrep to see SIP conversations. Showing what the asterisk log has during this time would be useful as well.

Hi I see the attempt:

REGISTER [email protected] [email protected] 20 192.168.1.114:50337 192.168.1.109:5060

Log:

02-23 17:54:18] VERBOSE[3672] netsock2.c: Using SIP TOS bits 96

[2022-02-23 17:54:18] VERBOSE[3672] netsock2.c: Using SIP CoS mark 4

[2022-02-23 17:54:18] ERROR[7822] tcptls.c: Unable to connect SIP socket to 192.168.1.115:5160: Connection refused

[2022-02-23 18:03:56] ERROR[3599] pjproject: sip_transport.c Error processing 2109 bytes packet from UDP 192.168.1.114:52077 : PJSIP syntax error exception when parsing ‘Request Line’ header on line 1 col 1:

ޭ??ޭ??ޭ??ޭ??8.1.109 SIP/2.0

Via: SIP/2.0/UDP 192.168.1.114:5060;branch=z9hG4bK17512f7b

From: sip:[email protected];tag=c0255c42da2200020aa63892-a886080f

To: sip:192.168.1.109

Call-ID: [email protected]

Date: Mon, 16 Jan 2017 08:57:18 GMT

CSeq: 1000 REFER

User-Agent: Cisco-CP7945G/9.4.2

Expires: 10

Max-Forwards: 70

Contact: sip:[email protected]:5060

Require: norefersub

Referred-By: sip:[email protected]

Refer-To: cid:[email protected]

Content-Id: [email protected]

Allow: ACK,BYE,CANCEL,INVITE,NOTIFY,OPTIONS,REFER,REGISTER,UPDATE,SUBSCRIBE

Content-Length: 1348

Content-Type: application/x-cisco-alarm+xml

Content-Disposition: session;handling=required

<?xml version="1.0" encoding="UTF-8"?>

SEPC0255C42DA22

192.168.1.114/24

192.168.1.1

CP-7945G

192.168.1.3

CISCO_3560

GigabitEthernet0/1

1

0

3

0

0

0

4095

192.168.1.109

-1

14845570322931484557036110

24

Sent:REGISTER sip:192.168.1.109 SIP/2.0 Cseq:107 REGISTER CallId:[email protected]

– end of packet.

It’s trying to connect over port 5160 instead of the 5060 you said earlier.

Thats the wrong device. The device is 192.168.1.114. I’ve done the following:

Changed the TCP chanpj_sip port for TCP to 5162
I’ve updated the port in my .XML file and uploaded it to the Cisco phone.
I’ve checked in extensions and it shows: This device uses PJSIP technology listening on Port 5060 (UDP), Port 5162 (TCP), Port 5061 (TLS)
Under the advanced tab in the extension the TRANSPORT is set to: 0.0.0.0-TCP

I see the register attempt:

REGISTER [email protected] [email protected] 2 192.168.1.114:49399 192.168.1.109:5162

Dont see anything in the log???

Unfortunately people new and on a budget pick them up on ebay a-lot… Unfortunately they don’t research first. These things have haunted the voip forums consistently for the last 15ish years

Gotta replace 100 phones… oh look $10 each

2 Likes

What is this? It looks far from being a valid REGISTER request.

The diagnostic is correct. In this case, the first six ?s should be "REFER ", and the remaining two need to include at least six characters, “sip:”, a digit, and a dot.

Right got it working.
FreePBX extension has to have “Rewrite Contact” and “Force rport” both set to “No” in the FreePBX’s Extensions - Advanced Settings. “Rewrite Contact” allows it to register and “Force rport” allows RTP to be configured to communicate.

Without this the Cisco 79XX don’t seem to register. Thanks for all your help guys.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.