Announcements not working any more


#1

I just got a called, picked it up, but I did not hear anyone. After doing some testing it appeared my home number did work, but my business number doesn’t. The only difference is the announcement that is played before going to a ring group. When I disable the announcement all is well. Also voice mail announcements work.

What could this be?


(Dave Burgess) #2

It could be in the logs.


#3

Any idea what to look for? File not found, something like that? The file does play in the browser.


(Lorne Gaetz) #4

Get a full call trace of a failed call and share via pastebin:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


#5

@lgaetz Is this what you are looking for? https://pastebin.com/jpqjawAp


(Lorne Gaetz) #6

If the linked inbound call was supposed to play an announcement, it looks like it should have been around line 74:

[2020-01-09 20:01:49] VERBOSE[8638][C-00000026] pbx.c: Executing [s@dynroute-3:7] GotoIf("SIP/cheapconnect-0000001d", "0?app-announcement-4,s,1") in new stack
[2020-01-09 20:01:49] VERBOSE[8638][C-00000026] pbx.c: Executing [s@dynroute-3:8] Goto("SIP/cheapconnect-0000001d", "dynroute-3,1,1") in new stack
[2020-01-09 20:01:49] VERBOSE[8638][C-00000026] pbx_builtins.c: Goto (dynroute-3,1,1)
[2020-01-09 20:01:49] VERBOSE[8638][C-00000026] pbx.c: Executing [1@dynroute-3:1] Goto("SIP/cheapconnect-0000001d", "timeconditions,3,1") in new stack
[2020-01-09 20:01:49] VERBOSE[8638][C-00000026] pbx_builtins.c: Goto (timeconditions,3,1) 

Call goes to the dynroute module, there is a condition that evaluates to false so the app-announcement doesn’t play. It then goes on to the time condition.


#7

Thanks for digging… funny thing: my phone rings, I can pick up, but I don’t hear the caller. After disabling the announcement, all is fine. So I guess the route is fine, right?


(Lorne Gaetz) #8

No sure what’s going on, but some providers don’t appreciate calls being answered immediately or they require SIP ringing/progress to be sent back before the answer. There are some options in the Inbound Route such as pause before answer and signal ringing that you can experiment with. Otherwise you will probably have to touch with the provider to find out what is going on.

edit - I assume you have the full RTP port range (udp 10k-20k) forwarded thru your router, but if not that is a good place to start.


#9

I will do some A-B testing… My FreePBX is running on my local LAN, so ports are probably not the issue.


#10

I ended up deleting the ring group and re-creating it… now all works like it did before.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.