Analog line not playing IVR when another call in IVR

Hello!

Recently we changed our old [email protected] installation to a brand new FreePBX. Everything is working fine so far, but there is something I have been trying to fix.

We have a main DAHDI trunk, that is our main contact phone, connected to port 1. When we receive a call, the inbound route takes the call to an IVR and then to the selected extension.

The thing is, when someone calls and there is another call in the line (playing the IVR, for example), the line is not recognized as “busy”. Instead of the busy tone, we are having a ringback tone untill the call hungs up.

I have been looking in the trunk, route and IVR configuration an I wasn’t able to find the right parameter to change this. Any idea how I can achive this?

Also, is there any alternative methods to handle calls when line is busy aside the voicemail?

Thank you in advance.

If you have an single FXO port, then the ringback is coming from the provider, there is no way to take two calls on one pstn port, If you have several FXO’s in a “hunt group” from your provider, then just add them all to the same group.

Thanks for the answer! Currently we just have 2 FXO ports in use. Each port is used for a different phone number, one for outgoing and both can take incoming calls, but each PSTN belongs to a different phone number.

I understand there is no way to take two calls from the same PSTN port, that’s why I don’t get why the ringback tone instead of busy. Is it possible that FreePBX is not announcing that is busy correctly?

Sounds alone you have call waiting enabled with your carrier. On a analog line ring back is handled by the carrier not your PBX.

1 Like