An outdated version of the Asterisk DPMA module was detected


(Jerry Warner) #1

For the past few days I’ve been getting an error message “An outdated version of the Asterisk DPMA module was detected. Please upgrade to a supported version to ensure uninterrupted usage of DPMA supported phones”. I’ve searched the WIKI and the community pages but everything says that this should go away when I do regular system updates. But it doesn’t.

I’m running a Sangoma appliance version of FreePBX with 15.0.17.32 installed. Module updates and system updates have been performed as well as running yum update to make sure nothing slipped past me there. Asterisk is version 13.32.0

What am I missing?


#2

No answer for you, but I just started experiencing this same error in the Dashboard after performing a “yum upgrade” and “fwconsole ma upgradeall”.

Currently have
FreePBX 15.0.17.34
Asterisk 16.17.0

We don’t use Digium phones, so I’m not seeing any adverse impacts.
It would just be nice to clear what appears to be a Critical Error in our dashboard.


#3

After further research and following links I thought I found my solution here:
https://wiki.sangoma.com/display/FPG/EPM-DPMA+for+Digium+Phones

We are using the commercial Endpoint Manager and the instructions there seemed promising. However, I cannot complete the instructions because we don’t use Digium phones. I got as far as completing steps 1 - 3. Step 4 made no sense, since I have no Digium phones.

Looking elsewhere I found more resources

Ultimately I ran the ‘rpm’ command and got the following result
rpm -qa|grep res_digium
asterisk16-res_digium_phone-3.6.3-2.sng7.x86_64

Then I tried the migration steps here
https://wiki.freepbx.org/display/FPG/EPM-DPMA+for+Digium+Phones#EPM-DPMAforDigiumPhones-MigratingfrompreviousEPM+DPMAtoNewDPMA

But was never presented the option to migrate.

And the SSL warning is still there.


(Jerry Warner) #4

That sounds a lot like my own journey. We both ended up in the same spot. We have a “critical error” that doesn’t effect us as we don’t have Digium phones. But it would be nice to get rid of this error message. Frankly, I’m a bit surprised my post has been up this long with no replies until now. I was starting to think I was the only one with the problem and resigning myself to the fact that I’d probably always have the error in the Dashboard.

The WIKI says it will go away with the normal update process but obviously it does not.


(Lorne Gaetz) #5

Whenever you upgrade Asterisk (and most other system services), you must restart asterisk in order to get the new version.


(Jerry Warner) #6

Is there a way to do this short of a total reboot? I tried running the " **core restart gracefully" command and it completed successfully however the critical error is still on the Dashboard.


#7

try

fwconsole notifications --list

then

fwconsole  notifications --delete appropriatemodule appropriateID 


(Jerry Warner) #8

Dicko,

Maybe I did something wrong? Below are my results.

Notifications Help:
Usage: fwconsole notifications [--list]
Usage: fwconsole notifications [--delete module id]

fwconsole notifications --list
+---------------+----------------------+--------------------------------------------+
| Module        | ID                   | Text                                       |
+---------------+----------------------+--------------------------------------------+
| digium_phones | digium_phone_dpmassl | Asterisk (DPMA) SSL Certificate Expiration |
| endpoint      | endpoint_dpmassl     | Asterisk (DPMA) SSL Certificate Expiration |
| firewall      | 1                    | Intrusion detection handling method        |
+---------------+----------------------+--------------------------------------------+
# fwconsole  notifications --delete digium_phone_dpmass1
Usage: fwconsole notifications --delete module id
Specified notification does not exist
# fwconsole  notifications --delete digium_phones
Usage: fwconsole notifications --delete module id
Specified notification does not exist
# fwconsole  notifications --delete digium_phones digium_phone_dpmass1
Specified notification does not exist

#9

You need to transpose Module and ID to what you actually see , for example

fwconsole notifications --delete digium_phones digium_phone_dpmassl

.
.
.
.

(Jerry Warner) #10

That worked…sorta. It looks like I actually had an extra space in my command line after “fwconsole” instead of being transposed.

It deleted the notification but it didn’t solve the problem on the Dashboard. In fact there’s now a new problem that wasn’t there before the deletion.

In addition to the DPMA SSL Certification error it now has a second error “Intrusion detection handling method” -Intrusion detection handling method is been updated recently. Please clear your browser cache and try if you are having issue with Intrusion Detection Start/Restart/Stop button.

Clearing the cache does not correct the new second issue.Nor does stopping and restarting the Intrusion detection.

[root@rrcs-24-142-161-61 ~]# fwconsole notifications --delete digium_phones digium_phone_dpmassl
Deleting notification
Notification Deleted

#11

if you have no investment in that module, how about just ‘deleting’ it


(Jerry Warner) #12

Which module, the intrusion detection?

I don’t know enough about this stuff to start just deleting things. Sounds like I could hurt myself pretty badly that way. I don’t have an Digium phones but it sounds like this is a part of Asterisk? I’m not smart enough to know what else might be effected, or how to delete the module safely.


(Lorne Gaetz) #13

I assume that people in this thread reporting the warning are actually dismissing the warning from the dashboard, correct? And that it comes back after you dismiss? I’m unable to reproduce this.


(Reinhard Stindl) #14

The message in the dashboard about the DPMA certificate is actually a feature not a bug. Many Digium phone users would be surprised, when in May their phones suddenly stop working. I have no idea, why the warning message does not disappear once you updated the DPMA-module.
Could you please check what version of DPMA you are using?
Go to Connectivity>Digium phones>general settings and tell me what it says in the dpma version field.


(Lorne Gaetz) #15

If this module is not installed, you can get DPMA version from the asterisk console with:

*CLI> digium_phones show version
Digium Phone Module for Asterisk Version 16.0_3.6.3

(Reinhard Stindl) #16

In either case…once you checked the DPMA-Asterisk version…you will find out that you have an old one <3.6.2
Then…go to admin, module admin and update your system (not the modules…you want the system-updates-tab! But only do it, if you have a standard distro with an unpatched Asterisk…
module_admin


(Jerry Warner) #17

I hadn’t tried just dismissing the notice. I didn’t think that would make the problem go away but would be more like putting my hands over my eyes and pretending it doesn’t exist. Generally pretending a problem doesn’t exist is a bad idea and gets you in trouble sooner or later.

But you are right, I dismissed the error just now and reloaded the page and the error is gone. Hands are firmly against the eyes. I see no evil here.


(Jerry Warner) #18

In the General Settings under Digium phones it says I’m running DPMA version 3.6.

As noted in my reply to Lorne, the dashboard does show no errors after I dismissed the warning.


(Reinhard Stindl) #19

The warning may come back, the next time you update your freePBX modules. You can, of course, dismiss it again. The version must be 3.6.2 or higher. The Asterisk DPMA module is not a freePBX module, therefore you can only update it, when you do a module-admin_system-updates update as shown above. Yet, you dont have to, when you dont use the Digium phones.


(Jerry Warner) #20

I’ve done all the module-admin-system-updates. That’s had no effect on this issue.