AMPUSER db entry?


       Guys I am having the following trouble after converting a "trixbox" to make asterisk read all sip.conf through a Realtime MySQL database.

       My problem comes when I add users to the realtime database and it works great, the extension is registered and can make outgoing calls BUT I can not receive incoming calls to that extension.

      I am posting this to the freepbx mailing list since after some research I could find out this:

      recordingcheck|20071023205357|1193183637.4460: No AMPUSER 

db entry for 211. Not recording
recordingcheck|20071023-205357|1193183637.4460: Inbound recording
not enabled
dialparties.agi: Starting New Dialparties.agi
dialparties.agi: Caller ID name is ‘XXX’ number is '202’
dialparties.agi: Methodology of ring is ‘none’

     I can see that recordingcheck.php [AGI script that comes with Trixbox] tells me "No AMPUSER db entry for 211" where 211 is the extension I created  manually not using FreePBX.

   Then I did this and found this difference between extension 202 that was created through FreePBX and ext. 211 that was NOT created through freepbx:

[[email protected]]# asterisk -rx ‘database show’ |grep 211
/CALLTRACE/211 : 202
/SIP/Registry/211 : 200.xx.xx.xx:
/SIP/Registry/859 : 2xx.xx.xx.xx:
/SIP/Registry/860 : 2xx.xx.xx.xx:
[[email protected]]# asterisk -rx ‘database show’ |grep 202
/AMPUSER/202/cidname : Juan Perez
/AMPUSER/202/device : 202
/AMPUSER/202/outboundcid :
/AMPUSER/202/recording : out=Never|in=Never
/AMPUSER/202/voicemail : default
/CALLTRACE/111 : 202
/CALLTRACE/202 : 201
/CALLTRACE/203 : 202
/CALLTRACE/210 : 202
/CALLTRACE/211 : 202
/CALLTRACE/212 : 202
/CALLTRACE/701 : 202
/CALLTRACE/702 : 202
/CALLTRACE/900 : 202
/DEVICE/202/dial : SIP/202
/DEVICE/202/type : fixed
/DEVICE/202/user : 202
/SIP/Registry/202 :

So when I read recordingcheck.php I comment the “exit(1)” in the if() where the AMPUSER is not found. This didn’t work.

I would appreciate if you could tell me where this “AMPUSER” is stored [ it says in a “db” ], where? How can I add it manually? Or even better, how can I skip this checking?

In this box I had to started using Realtime so unfortunately I won’t use FreePBX there but I made the post here since “AMPUSER” looks like something related to FreePBX.

Thanks in advance!


FreePBX is not at all designed to run in Asterisk Realtime mode. If you have a need to do that, then you should be running with your own dialplan. You will run into all sorts of problems. An extension is much more than “sip/NNN” in FreePBX and it expects all sorts of stuff to be setup to run properly.

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

I know Phillipe but I would be migrating since the dialplan is pretty complex so far.

I am just interested on where is that AMPUSER db to make my own INSERT or just a trick on how to skip that checking.


go sift through the articles in the “Technical Corner” it explains much of this.

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

Would that be a way of “inserting” the AMPUSER values to the database?

database put AMPUSER/211 outboundcid “Juan Perez"
database put AMPUSER/211 device 211
database put AMPUSER/211 recording "out=Never|in=Never"
database put AMPUSER/211 voicemail default