Allowing Polycom 601's to Recieve Pages (EPM)


(BGM) #1

When my Polycom 601, that I’ve configured via commericial EPM receives a page, it rings instead of auto-answering.

I’ve done this manually on another server by editing the sip.cfg for that model of phone.

  <alertInfo 
    voIpProt.SIP.alertInfo.1.value="Auto Answer" voIpProt.SIP.alertInfo.1.class="3" 
    />

But if I go through the settings in EPM to edit the basefile for that model, I see:

  <voIpProt.SIP.alertInfo
    SIP.voIpProt.SIP.alertInfo.1.class="ringAutoAnswer"
    SIP.voIpProt.SIP.alertInfo.1.value="Auto Answer"
  >

Should I just change it all to match my manual settings? What should it be? I see that my entry differs only in “class”.


How to test Automatic Page Group without schedule?
(Tony Lewis) #2

It should already auto answer. EPM sets this up.


(BGM) #3

Mr. Lewis,
It auto-answers, but it rings before it answers on the polycom 550.
The polycom 601 just rings and doesn’t answer.

Now, all my extensions are set to chan_sip, and that is what is enabled in Advanced Settings.
In the asterisk console, when I make an intercom call, I see this (and I haven’t tinkered with the asterisk files):

[2014-12-03 20:58:19] ERROR[25016][C-000000b4]: pbx.c:4387 ast_func_write: Function PJSIP_HEADER not registered
[2014-12-03 20:58:19] ERROR[25016][C-000000b4]: pbx.c:4387 ast_func_write: Function PJSIP_HEADER not registered

(BGM) #4

Mr. Lewis, I made a complete fresh install of version 12 and neither polycom 550 nor polycom 601 will auto-answer. It was discovered that there are some errors in the basefile configuration. I was working with Mr. lorsungcu (from irc) and will be placing a regular ticket with our findings.


#5

Definitely does not work out of the box with 601s. Tested with factory defaulted 601 and a brand new freepbx install, using 6.12.65 64bit, latest modules, all system updates. It works with 550s, not with 601s. We resolved it by replacing ‘ringAutoAnswer’ with ‘3’, as bgm said.


(BGM) #6

After I updated the EPM to 14.0.23 and rebuilt some config files, now my Polycom 430’s no longer receive intercom or pages. They just ring like normal. This used to be working but now I can’t repair it, even by downgrading EPM.

Settings I have tried, by entering them in legacy_sip.cfg:

<alertInfo voIpProt.SIP.alertInfo.1.value="Auto Answer" voIpProt.SIP.alertInfo.1.class="4"/>
<alertInfo voIpProt.SIP.alertInfo.1.value="Auto Answer" voIpProt.SIP.alertInfo.1.class="3"/>
<alertInfo voIpProt.SIP.alertInfo.1.value="Ring Answer" voIpProt.SIP.alertInfo.1.class="4"/>
<alertInfo voIpProt.SIP.alertInfo.1.value="Ring Answer" voIpProt.SIP.alertInfo.1.class="3"/>
<alertInfo voIpProt.SIP.alertInfo.1.value="ringAutoAnswer" voIpProt.SIP.alertInfo.1.class="3"/>
<alertInfo voIpProt.SIP.alertInfo.1.value="ringAutoAnswer" voIpProt.SIP.alertInfo.1.class="4"/>

I’m leaving this in the same thread because it’s bascially the same problem. Something must have changed in the way FreePBX manages the intercom dialplan differently? Anyone have a clue? I’ve spent a week trying to figure this out, and have read nearly every thread I can find on the internet. Maybe I’ll post a big list of links for y’all.

For the 430’s, the firmware is the highest version possible (it’s legacy after all).
I need help, please!


(Tom Ray) #7

A 5 year old thread doesn’t really have bearing on anything current but OK. I am noticing that this thread was started by you and re-opened by you and that not a single time have you shown your extension settings where you have confirmed that Intercom is enabled on the extension or any other form are Alert Info is being set and/or sent at all.

Where is an actual debug of a call where the intercom fails?


(BGM) #8

Mr. Ray, well! Thank you for kindly asking to see a debug and for asking to confirm that intercom is enabled. I appreciate being asked so that I might know that someone wants to see it. I hope nobody has been just waiting idly by to see if I would think of it myself.

screenshot_waterfox_339

As for the debug, here is the console output (pastebinned so as not to crowd things up here):
https://pastebin.com/YdMLgRAA
This is output from a call where I tried to intercom an ip430. If I intercom one of my 650’s the same way, it works.

In this case, alert info is set to this in legacy_sip.cfg

  <alertInfo 
	voIpProt.SIP.alertInfo.1.value="Auto Answer" voIpProt.SIP.alertInfo.1.class="3"
	voIpProt.SIP.alertInfo.2.value="Ring Answer" voIpProt.SIP.alertInfo.2.class="4"
/>

(BGM) #9

Hmmm. Nobody has any ideas I might try?


(Tom Ray) #10
<alertInfo
voIpProt.SIP.alertInfo.1.value="Test" voIpProt.SIP.alertInfo.1.class="ringAutoAnswer" se.rt.ringAutoAnswer.ringer="ringer10" />

Try those.


(BGM) #11

Thanks, Mr. Ray, I appreciate any ideas. I put that in my legacy_sip.cfg and rebooted the 430 and it has the same effect - two short rings and no auto-answer for the page/intercom.

Here is the console output:
https://pastebin.com/6VHERg36

I confirm that the phone is loading legacy_sip.cfg; it is in the [mac].cfg file, and when I check the config files loaded by the phone on the phone itself, it even says it’s loading that file. And there are not two instances of the alertinfo xml settings in the legacy_sip.cfg.

The Polycom 430 is using bootblock 2.70(11402_001) and Bootrom 4.1.4.0122.


(Tom Ray) #12

Now show this with sip set debug on so we can see how the headers are formed and actually sent to the device.


(Tom Ray) #13

Yeah, I got nothing for this. This model has been EOL for 4 years, it never got on the 4.0.x UC firmware. So at best it’s on 3.2.7 which is from 2012. So this phone is completely unsupported in regards to these features as it hasn’t had an update to match anything current over the last six years.

Even the first editions of the VVX series, 40x, 50x, 60x, etc. are no longer getting UC updates as of this year. The 5.9.x version is the last software version update for them and everything is at 6.0.x now for the new non-Obi VVX models.

But yeah this is sounding like it’s an issue with the phone and there isn’t anything you can really do about it.


(Tom Ray) #14

Also what version of the UC software is this VVX601 at? I don’t have problems with Intercom on my 601’s for clients but I also run the latest UC release on them.


(BGM) #15

Mr. Ray,
Here is the sip debug: https://pastebin.com/aWmcpVEN

I don’t have any VVX’s - they are SoundPoint IP601’s and SoundPoint IP430’s. I plan to replace the 601’s, but I have lot of 430’s. I know they are old.

It’s strange, but the intercom all worked on them until about 2 weeks ago after I ran updates on FreePBX.

They are using the firmware 1.11 from the EPM manager, which has 3.3.7 for the 430’s, and 3.1.8 for the 601’s.


(Tom Ray) #16

So did you update anything else besides EPM? The EPM would only be responsible for configuring the phone, not setting up the call headers for it to auto answer for the Intercom.

However, that said I just did update Framework, Core and Paging/Intercom to their latest releases and this is what I’m seeing now in the dialplan:

exten => s,n,ExecIf($["${USERAGENT:0:7}" = "Polycom"]?Set(ALERTINFO=info=Auto Answer))

This was what I had before the update:

exten => s,n,ExecIf($["${USERAGENT:0:7}" = "Polycom"]?Set(ALERTINFO=Alert-Info: Auto Answer))

Now the first one, the updated one, is wrong. Info= is for ring tones for the Polycom. It fully expects the Alert Info header to be what is in the latter dialplan (pre-update).

So it is clear that the generated dialplan was updated by someone which leads me to the question. Did someone in the QA team actually plug in a Polycom, set it up for auto answer and test the Intercom functions on it after the header details where modified?

This is like the CallerID HTML encoding bug from earlier this year where the quotes (") where not being decoded properly from the GUI submissions and ended up in the AstDB with the HTML entities vs the quotes. Which means no one checked the AstDB backend for the data being written to it or no one plugged in a phone and made a call to test it. Because either of those would have immediately flagged an issue.

While things like the CallerID bug will be reported pretty quickly because everyone makes calls the Auto Answer will only be caught by the subset using it. If it’s only for one of the six User Agents FreePBX looks for to set Auto Answer on, then that subset is even smaller.


(BGM) #17

A few weeks ago I ran system updates. It was soon after that when I began to have problems. I need to start writing down what the updates are before I run them - I can’t find any kind of an update log in the FreePBX GUI. There was something like 52 system updates. I updated EPM around the same time, I think.

Is there something I might try?


(Tom Ray) #18

Well since this is probably all handled by the Paging/Intercom module, you can try to downgrade that. Like I said, I only updated Core, Framework and Paging/Intercom and I found that change.


(BGM) #19

In my notes, I see I ran system upgrades on June 6. But I don’t recall having this intercom issue that far back. I think this started somewhere around August 23, when Commercial Support directed me to update EPM to 14.0.23. So, maybe it was an update I made to some other module at the same time.

So, I just tried to rollback to Paging and Intercom from 14.0.12 to 14.08, but it didn’t make any difference.
And if I look in extensions_additional.conf, I still see there the updated line for the alertinfo, like you pointed out. How many versions back would I go before we get to the original? If I go to Paging & Intercom 14.07 then I’d have to get an older version of Paging Pro as well (requires Paging & Intercom 14.08).


(Tom Ray) #20

I honestly can’t say. I would have to find a box that I could look at like that. I don’t run standard deployments of FreePBX, so updates like that don’t actually impact the dialplan I use for things. I can’t recall what version it was sitting on before I just did this update. It had to be 3 or 4 versions ago at least.